Experiment not running but no error output

OS: MAC (Catalina)
PsychoPy version: 2020.2.6 and 2020.2.5
When I try to run the experiment from builder, it asks for participant ID and then the screen briefly flashes gray before quitting out. I am not receiving any errors. Stdout is: #### Running: /Users/juliaschorn/Desktop/dotstest/new_pilotdots_lastrun.py #####

I had the same problem for both versions. When I downgraded, I had other errors that prevented it from running (Stdout mentioned that these problems are because I made the experiment on a newer version of psychopy).

No idea why it isn’t running or giving me errors…what should I do?

1 Like

How did you open the file? There were a few different things causing the stdout to be disconnected from the stream of error messages, most are dealt with in .6 but one persistent one is that the stdout was disconnected when PsychoPy is opened by double clicking a .psyexp file rather than opening PsychoPy and then opening a .psyexp in PsychoPy. In .7 this will be fixed! In the mean time, try opening the app first and see if you can see error messages then.

I saw that what you mentioned was a possible error in a different thread on this forum so I tried opening it from PsychoPy (instead of double clicking on the .psyexp file) and was continuing to get the same error. I also tried to double check my security settings (like other threads mentioned) and put PsychoPy in ‘input monitoring’, but that didn’t help either.

Does the error persist when you update to 2020.2.9?