psychopy.org | Reference | Downloads | Github

Microphone Causing Freezing

Hi, so I’ve seen a few other threads on this but none narrowed down the issue whereas I think I have. When dragging the microphone into the flow at any stage in the builder the program will fail to start and hang at a grey screen. This is an issue regardless of PsychoPy version and of method install. When trying to use the demo which records voice, an error keeps repeating:

Pyo error: Pyo built without Coreaudio support
Pyo error:
Server not booted.
Pyo error: The Server must be booted

I have installed Pyo already through terminal and this does not change. I’m assuming this is an issue with PsychoPy & MacOs. It would be great to get some feedback on this if anyone can assist.

Occasionally, this error appears as well and I’m not sure if this is the result of me having to cmd+Q out of the frozen screen:

ApplePersistenceIgnoreState: Existing state will not be touched. New state will be written to (null)

OS (e.g. Win10): Catalina 10.15.5
PsychoPy version (e.g. 1.84.x): 20.2.3
Standard Standalone? (y/n) If not then what?: Tried a few
What are you trying to achieve?:
Trying to record audio through the microphone

What did you try to make it work?:

*Reinstall Psychopy through different methods, standalone, homebrew
*Reinstall different Psychopy versions
*Installed pyo using pip
*Changed the order in which the microphone appears in the flow

Thanks ! :slight_smile:

I’m having the same issue!

Unfortunately this community is not very active and I couldn’t find a solution. I ended up installing windows and doing work on there as it worked flawlessly. I guess Mac just isn’t as well supported, shame really.

I am experiencing the same problem with my mac.