psychopy.org | Reference | Downloads | Github

List Variable Not Imported


#1

URL of gitlab repo: https://gitlab.pavlovia.org/djangraw/losasurveytask/
URL of experiment: https://pavlovia.org/run/djangraw/losasurveytask/html/

Description of the problem: I have a loop-conditions file with parameters Page, Instr, Quest1, Quest2, …, Quest6. In the routine in that loop, I have text objects (InstructionsText and text1) whose text are set to Instr and Quest1. While the text of the first object is set to Instr without incident, when trying to set the second to Quest1, it throws an error saying “ReferenceError: Quest1 is not defined.” So when the loop-conditions file is imported, the variable Instr seems to be created without a problem, but Quest1 is not. The experiment runs fine locally in Python.


#2

Hi @djangraw, are you still getting the error? I have just run your task in the link above and it worked ok.


#3

No, after leaving it overnight, it seems to have stopped! That’s great.

I’m actually running into a similar problem today where javascript changes I make locally and sync with Pavlovia don’t seem to take hold right away… @dvbridges, do you know if there’s any way to speed up that process, or how long I should expect it to take for changes to “go live” in the runnable version?


#4

Sometimes you need to force refresh your browser cache. See the link below for different platforms and browsers:


#5

Thanks - that’s very good to know!

This works well for the experiment, but the resource file (loop-conditions .xlsx file) is still not updated. That is, while https://gitlab.pavlovia.org/djangraw/losasurveytask/raw/master/html/resources/SurveyListShort.xlsx has updated, https://pavlovia.org/run/djangraw/losasurveytask/html/resources/SurveyListShort.xlsx has not. Is there another step I should try?