psychopy.org | Reference | Downloads | Github

Issue displaying specific stimuli

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): PsychoPy 2020.2.5

What I have is a series of trials that ask a question coupled with a slider to ask for a probability on the same screen.
image
trials: a loop that references an excel spreadsheet
outer.xlsx (8.5 KB)
response: a textbox, a slider, and a keyboard input to confirm their answer before continuing.
This is what I have in the textbox $'What is the probability ’ + prof
This works for every single trial except one. The last one in the excel spreadsheet.
presdurat/5.xlsx Molly is an aerobics instructor?

It will display the trial correctly, but when it goes to the response screen nothing appears except “NaN”. Now the interesting thing is that is has nothing to do with it being occuring on the final trial, as I have removed that specific trial and it works fine. Same thing is if I have that trial anywhere else in the spreadsheet, or in the experiment, it will display “NaN” still. I thought it might be due to the length of that variable, but the trial “Lilly is a kindergarten teacher?” displays correctly in my experiment.

Any ideas on why psychopy does not like aerobics instructors? haha

I’ve tried changing the size of my text box and it’s positioning. As I thought it might be something to do with maybe the text overlapping with my slider, but it did nothing. I also deleted some of the “Molly is an aerobics instructor?” line in my excel file, so it is just “Molly is an aerobics” but that also still only returned NaN for the entire response screen. No slider, or keyboard response or anything. It’s positioning in my excel loop list also does not matter, it will occur if it is at the end, the beginning or in the middle and only that one trial. I am really stumped :confused:

I’m intrigued. Please could you add me as a developer or send me the psyexp file and resources?

Like just in this forum or as a private message?

Either depending on whether you’re happy for anyone to download it or not.

It was quite a few files, so for the sake of cleanliness I just you a message haha.

1 Like

I think that the issue might be with the file presduar/5.xlsx

The experiment thinks that there is an additional row but with no duration it doesn’t end.

Try moving the cursor to cell A1, resave and reupload

It must have been something like that. I just recreated the excel file and it worked fine. Thanks!