psychopy.org | Reference | Downloads | Github

Install PsychoPy on a computer with Python 3.7.0

installation

#1

I am trying PsychoPy. My Windows 10 computer has already installed Python 3.7.0 (the version from python.org, just Python). I installed the standalone version of Python (StandalonePsychoPy3-3.0.2-win32). No problem in installation. However, when I tried to start it using the icon, nothing happened. No splash screen. Nothing. I tried to call it from command prompt and see what happened:

"C:\Program Files (x86)\PsychoPy3\pythonw"  "C:\Program Files (x86)\PsychoPy3\Lib\site-packages\psychopy\app\psychopyApp.py"

Nothing happened. Not even an error message.

Does anybody know how to solve this problem? I install the standalone version because I don’t want to affect the existing Python installation. However, if it is the only solution, than I would try to install it inside my existing Python installation.

P.S.: It should not be about the settings at AppData. I found the folder, but nothing there. It seems that PsychoPy has never successfully started on my computer.


#2

Hi @sfcheung, if I run the code you pasted, I get an error because of the ‘>’ symbol in your path to the Python interpreter. Does it work if you try:

"C:\Program Files (x86)\PsychoPy3\pythonw" "C:\Program Files (x86)\PsychoPy3\Lib\site-packages\psychopy\app\psychopyApp.py" 

#3

Thanks, @dvbridges, sorry for my typo. I did type what you suggested (from the shortcut created during installation). The code in the original post was created by copy-and-paste with edit and I did not notice the “>” from the command prompt.