How to solve the issue of the "initialising the experiment" screen

Description of the problem:
I have managed to sync my psychopy experiment to pavlovia but when I tried it to run it online either from the builder or pavlovia a white screen with a message “initialising the experiment”. I’ve waited about 18 minutes but nothing has changed. Anyone encounter such issue?

Dear Ghozs Elotee

there are 50+ threads in this forum with the same error message

Psychopy to Pavlovia code error: stuck on initialising experiment code error

Stuck on Initialising Experiment

aso. You might to take a look at those first.

best wishes Jens


for recent context I would also recommend the same as here Need your help about the issue "initialising the experiment" screen

Thank you for your replies

I’ve tried to read through the cribs sheet, but still unable to figure out the syntax error
here is the link to the study


Looks like you have a text stimulus with a blank entry in the ‘text’ (textblank500) try adding a space as a placeholder :slight_smile:


Thank you Becca. I’ve added a space in in the ‘text’ (textblank500) and ran it online but no change.
I’ve removed blank500 from the experiment and I still have the initialising experiment code error.

Hi There,

I think this is because you had other components that has text components with blank spaces.

My forked copy of your task doesn’t get stuck on the initializing page :slight_smile:


1 Like

yes, we had the same problem here. It seems that the behavior has changed recently. When we collected data earlier this summer, empty text boxes caused no problems. But now when we tried to run the same study it got stuck on the initialization screen on pavlovia, which was due to an out of place comma in the javascript code. I can confirm that adding a space to the text box fixed the problem.

1 Like

Thank you Becca and Henning for your help.
I’ve removed the Blank500 text stimuli. I have checked other text boxes, they are all with texts. I can’t find where the other empty text boxes to add apace. Can I do it from pavlovia? I’ve seen the forked copy but can’t find the same line in the html files.

Hi Ghoza. I would run the study on pavlovia using Chrome as a browser. When it gets stuck on the initialization screen, open the developer tools (click on the 3 dots in the upper right -> more tools -> developer tools. Then within developer tools, click on console. It will tell you in which line of your javascript code there is an error. Open the javascript code using a text editor. Then you will see which routine is causing problems.

1 Like

Hi There,

Just pull the .psyexp file from my forked project and replace your own .psyexp - you do not need to make any edits beyond that to code etc :slight_smile:


1 Like

Thankyou for that!

I’ve just tried that and finally it works, the initialising stuck screen gone away. I’m not sure why the screen color in the online version is black whereas in the builder I set it to be white, Any idea?

Fantastic - please can you mark the corresponding answer as the ‘solution’ for future users :slight_smile:

the background colour should reset if you reset the size of the browser window - this is to do with one of the JS libraries (pixi) currently implemented but should be sorted soon (I think @sotiri?) for now you could add a large polygon/rectangle component that is white and make sure to have that component listed first in all of your routines (it will ensure things ‘look’ as you expect when you go online).

Hope this helps