psychopy.org | Reference | Downloads | Github

GitLab commits not reflected on Pavlovia

URL of experiment: Sign in · GitLab

Description of the problem: For a little while I have been piloting and running my experiment with no issues. I could change my code, and the experiment would then run differently on Pavlovia, as desired. But suddenly, the interface for my experiment has stopped changing in accordance with changes to the JavaScript in my GitLab repository. I have tried both piloting and running; either way, none of my commits is reflected on Pavlovia.

There’s a good chance I caused the problem. Here’s how. In a recent version of my code, I used the jsPsych html-keyboard-response plugin in the second-to-last trial in my timeline. I set the choices parameter to jsPsych.NO_KEYS, but I did not set the trial_duration parameter to anything. In other words, I kept the trial from being terminated by keyboard input, and I didn’t tell it to automatically terminate a certain period after starting. In effect, I prevented that trial’s terminating at all. So then when I ran this version of the code, the final “trial” in the timeline—pavlovia_finish—must never have been reached. (Evidence: the data didn’t get saved in my GitLab repo.) Maybe Pavlovia is behaving as though that test run never ended, even though I exited and clicked “Leave.”

And maybe Pavlovia refuses to run new versions of the experiment until it thinks it’s finished with runs initiated before those versions were committed. However, the experiment page does say that run was “aborted.”

I tried to resolve the problem with a recent GitLab commit, editing the JavaScript to allow a random keystroke to terminate the penultimate trial. But apparently the problem is nullifying my efforts to resolve it. Where to go from here?

If Pavlovia refuses to run the latest upload of your experiment, disable the cache via Network conditions in the browser console. You may also need to clear the cache when you first set this (using Ctl-F5, Ctl-Shift-R or equivalent). When you have developer tools showing you can also press and hold the page refresh icon and select Empty Cache and Hard Reload.

1 Like

That did the trick! Thanks.