psychopy.org | Reference | Downloads | Github

Gettin "unknown resource" error when piloting on Pavlovia

URL of experiment:
https://gitlab.pavlovia.org/noahhjelle/websurf4

Description of the problem: After testing the code on multiple computers, both mac and pc, it was able to run without issue. However, when trying to pilot the same code online it has issues with all of the images and video files. The files are all in the resources folder, but I have tried moving them to different locations, which didn’t fix the problem. I have tried both types of slashes in the file names and tried renaming the files, making sure all the names were typed correctly, but still no solution. What could be causing this error?

Also, as a side question, is there a more detailed error log when piloting an experiment on Pavlovia, it feels like the error given isn’t very informative.

I have included a screenshot of the error message as well as a link to the code which will hopefully work.

I appreciate any input!

Hi @noahhjelle, looks like the issue is the use of absolute paths in your image stim e.g., C:\\Users\\Noahh\\WebSurf\\img\\_clockwise3 . To fix, you need to make your paths relative to you project directory e.g., /WebSurf/img/_clockwise3, also you should give your filenames an extension.

Thanks for the response! That’s in the javascript file correct? What would cause it to have the absolute paths there when it looks like the python file has the relative paths? Is the easiest way to fix this just to go into that file and change by hand after I’ve converted the python file to javascript?

It is in the actual image components, e.g., your image component called practice_img2.

So I still see the error even after changing the file paths, and I tried this with the slash in the other direction as well. It looks like this now:

I think you are going to need to provide the file extension as well, also you need to use forward slashes in your paths for JavaScript. Let me know if these things work.

Yes that fixed it, thank you!