First trial in a loop is skipped/stalled

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 2022.2.5
Standard Standalone? (y/n) If not then what?:y
What are you trying to achieve?:
In all of our experiments, the first routines of the first trial in the loop always gets skipped and/or stalls. Specifically, on the screen immediately preceding the loop in every task, the response required to get to the next screen (the start of the loop) is to press the space bar, but once the participant does this the screen stalls and doesn’t immediately go to the next screen. Because of this, any responses the participant makes on the first trial in the loop are not properly recorded. We cannot identify the problem causing the issue. Importantly, when these tasks were done on a laptop, this was not a problem - it only became a problem when transferred to a PC. (As a side note: the laptop has the most recent version of PsychoPy, whereas the PC has an earlier version.)
What did you try to make it work?:
We tried re-creating the experiments in PsychoPy on the PC computer (rather than just transferring the tasks from the laptop to the PC) to see if this might be causing the issue. We also tried changing how the stimuli in the first trial are presented (changing from “constant” to “set every repeat” to “set every frame”). Additionally, we tried adding a code component that counted the trials.
What specifically went wrong when you tried that?:
Include pasted full error message if possible. “That didn’t work” is not enough information.
Recreating the tasks in the PC (rather than transferring them directly from the laptop) still gave the same stalling issue, as did changing how the stimuli are presented. Setting the stimulus to “constant” on the screen immediately preceding the loops fixed the trial skipping problem (on some of the tasks), but it still presented a delay in the trial and the participant responses in the first trial were not recorded because of this. Adding in a code component to count the trials did not do anything for the delay.