psychopy.org | Reference | Downloads | Github

Failing to sync with Pavlovia using conda-installed PsychoPy

OS: Fedora 29
PsychoPy version : 3.0 installed through conda
What are you trying to achieve?:
Sync with pavlovia. However, when I try to login the following message appears:

Unable to load page
Problem occurred while loading the URL https://gitlab.pavlovia.org/oauth/authorize?client_id=4bb79f0356a566cd7b49e3130c714d9140f1d3de4ff27c7583fb34fbfac604e0&redirect_uri=https://gitlab.pavlovia.org/&response_type=token&state=25679d58-4dd6-468e-bf78-9ee3630c39bc

TLS/SSL support not available; install glib-networking

What did you try to make it work?:
Tried to install the glib-networking through the commands below. The instalation was fine but the message persisted.

sudo dnf install glib-networking
conda install -c anaconda glib-networking-cos6-x86_64

Sorry, don’t know enough about Fedora to know why this doesn’t work. What if you go to a terminal (or a browser) and try that link? Does it work there?

Hi, thank you for helping.
But I don’t think it is specific to Fedora. Here, someone had the same problem with Linux Mint (https://github.com/psychopy/psychopy/issues/1979).

I tried the link on browser and it opens pavlovia home page. On terminal:


[andresimi@andredesk ~]$ https://gitlab.pavlovia.org/oauth/authorize?client_id=4bb79f0356a566cd7b49e3130c714d9140f1d3de4ff27c7583fb34fbfac604e0&redirect_uri=https://gitlab.pavlovia.org/&response_type=token&state=25679d58-4dd6-468e-bf78-9ee3630c39bc
[1] 12617
[2] 12618
[3] 12619
bash: https://gitlab.pavlovia.org/oauth/authorize?client_id=4bb79f0356a566cd7b49e3130c714d9140f1d3de4ff27c7583fb34fbfac604e0: Arquivo ou diretório inexistente
[2]-  Concluído              redirect_uri=https://gitlab.pavlovia.org/

Any thoughts on this? I tried on Ubuntu and it is the same. Maybe it is related to Anaconda? Unfortunately I could not install through pip…

It worked for me when I used a pip-installed version of PsychoPy instead of a conda-installed version and launched it with no conda enviroment activated.

Just reporting that I’m also unable to log in through the builder with a recently installed psychopy. I am working with

OS: Ubuntu 18.04.03
PsychoPy: version 3.2.4, installed with pip in a conda environment

the following suggests that glib-networking is installed

sudo apt install glib-networking
Reading package lists... Done
Building dependency tree       
Reading state information... Done
glib-networking is already the newest version (2.56.0-1).

fwiw, I get these messages when starting up PsychoPy

GLib-GIO-Message: 14:13:32.145: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
02:13:32 PM: Debug: Adding duplicate image handler for 'Windows bitmap file'
02:13:32 PM: Debug: Adding duplicate image handler for 'Windows bitmap file'
02:13:32 PM: Debug: Adding duplicate image handler for 'Windows bitmap file'

I’d be happy to try out some suggested fixes, but if possible I’d rather not work with psychopy without an environment (which @mkallmayer says will work)

thanks!

How did you install PsychoPy via conda? The recommended way is described here. In short:

  • download the environment file
  • create the environment via conda env create -n psychopy -f psychopy-env.yml
  • activate and use the environment

Thanks for the response, @richard. I followed the Anaconda instructions from https://www.psychopy.org/download.html.

Following the linked instructions, I’m still unable to login. But, there’s a different set of messages when starting up psychopy (copied below)

Gtk-Message: 21:55:51.457: Failed to load module "overlay-scrollbar"
Gtk-Message: 21:55:51.458: Failed to load module "atk-bridge"
Gtk-Message: 21:55:51.460: Failed to load module "canberra-gtk-module"
09:55:51 PM: Debug: Failed to connect to session manager: None of the authentication protocols specified are supported
09:55:52 PM: Debug: Adding duplicate image handler for 'Windows bitmap file'
09:55:52 PM: Debug: Adding duplicate image handler for 'Windows bitmap file'
09:55:52 PM: Debug: Adding duplicate image handler for 'Windows bitmap file'

Thanks @psadil. Could you try to follow the instructions I linked above and see if that helps?

Hi @richard. Sorry for not being clear. I did try the instructions you linked to; by ‘linked instructions’ I meant the instructions that were linked to by you.

To be extra clear, I first tried https://www.psychopy.org/download.html, ran in to the log in trouble, posted here for the first time, tried the instructions you linked to, but was still unable to log in. The output I copied in my last message (beginning with Gtk-Message) was from starting psychopy in an environment created with the linked to environment file.

edit: conda version 4.7.12

Thanks for the clarification, @psadil.

Unfortunately, GTK currently is not packaged for conda-forge, so it seems some packages have to be installed manually on Linux. Could you please run the following command and see if that fixes the error messages for you?

sudo apt install overlay-scrollbar-gtk2 \
                 libatk-adaptor \
                 libgail-common \
                 libcanberra-gtk-module

Looks like those packages were already installed. See the output below

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libatk-adaptor is already the newest version (2.26.2-1).
libatk-adaptor set to manually installed.
libgail-common is already the newest version (2.24.32-1ubuntu1).
libgail-common set to manually installed.
libcanberra-gtk-module is already the newest version (0.30-5ubuntu1).
libcanberra-gtk-module set to manually installed.
overlay-scrollbar-gtk2 is already the newest version (0.2.17.1+16.04.20151117-0ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

This is weird indeed. I will try to install Ubuntu in a virtual machine tomorrow and attempt to replicate your issue.

Just for the record, how did you install conda? Via the miniconda distribution?

@richard, thanks for taking the time to help.

I’ve been working with the full Anaconda distribution (which had been installed by following the basic install instructions) Not sure about @andresimi or @mkallmayer.

This is just me stumbling around. but when I install followed the Linux instructions inside a conda environment, that is use pip to install psychopy,

conda create --name psychopy python=3.6 pip
conda activate psychopy
pip install psychopy psychtoolbox
# download wxPython from https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ into ~/Downloads 
pip install ~/Downloads/wxPython-4.0.7.post2-cp36-cp36m-linux_x86_64.whl

I got a new useful error message (note also that lack of errors about gtk2 etc.)

09:32:46 AM: Debug: Adding duplicate image handler for 'Windows bitmap file'
09:32:46 AM: Debug: Adding duplicate image handler for 'Windows bitmap file'
09:32:46 AM: Debug: Adding duplicate image handler for 'Windows bitmap file'
Traceback (most recent call last):
  File "/home/psadil/anaconda3/envs/psychopy/bin/psychopy", line 8, in <module>
    sys.exit(main())
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/psychopyApp.py", line 100, in main
    start_app()
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/psychopyApp.py", line 28, in start_app
    app = PsychoPyApp(0, showSplash=showSplash)
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/_psychopyApp.py", line 182, in __init__
    self.onInit(testMode=testMode, **kwargs)
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/_psychopyApp.py", line 218, in onInit
    from psychopy.app import coder, builder, dialogs
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/coder/__init__.py", line 9, in <module>
    from .coder import *  # pylint: disable=W0401
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/coder/coder.py", line 22, in <module>
    import psychopy.app.pavlovia_ui.menu
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/pavlovia_ui/__init__.py", line 19, in <module>
    from .functions import *
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/pavlovia_ui/functions.py", line 13, in <module>
    from ._base import PavloviaMiniBrowser, PavloviaCommitDialog
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/app/pavlovia_ui/_base.py", line 9, in <module>
    import wx.html2
  File "/home/psadil/anaconda3/envs/psychopy/lib/python3.6/site-packages/wx/html2.py", line 15, in <module>
    from ._html2 import *
ImportError: libwebkitgtk-3.0.so.0: cannot open shared object file: No such file or directory

Ah! Missing libwebkitgtk-3.0

sudo apt install libwebkitgtk-3.0-dev

Starting psychopy still gives warnings about Windows bitmap file, but I am able to login!

Other note, the provided psychopy-env.yml file still seems to be missing a few packages (in particular, libwebkitgtk-3.0-dev to allow login, but also overlay-scrollbar-gtk2, libatk-adaptor, libgail-common, and libcanberra-gtk-module). The full list of packages in an environment created with the provided .yml is copied below (conda list -n psychopy). I admit that I don’t know what rules conda uses for determining when to use system packages like libwebkitgtk-3.0-dev. But I suppose this all suggests that conda can sometimes prevent the use of packages which were installed with sudo apt, while an environment is activated (e.g., libwebkitgtk-3.0-dev is accessible when the environment is created manually but not when created with the current psychopy-env.yml)? Or maybe there’s a mismatch between the versions of one of the packages that I get with pip vs conda?

# packages in environment at /home/psadil/anaconda3/envs/psychopy:
#
# Name                    Version                   Build  Channel
_libgcc_mutex             0.1                        main    conda-forge
alsa-lib                  1.1.5             h516909a_1001    conda-forge
arabic_reshaper           2.0.15                     py_1    conda-forge
astunparse                1.6.2                      py_0    conda-forge
atk                       2.32.0               haf93ef1_0    conda-forge
backports                 1.0                        py_2    conda-forge
blosc                     1.17.0               he1b5a44_1    conda-forge
bzip2                     1.0.8                h516909a_1    conda-forge
ca-certificates           2019.11.28           hecc5488_0    conda-forge
cairo                     1.16.0            hfb77d84_1002    conda-forge
certifi                   2019.11.28               py36_0    conda-forge
cffi                      1.13.2           py36h8022711_0    conda-forge
chardet                   3.0.4                 py36_1003    conda-forge
configobj                 5.0.6                      py_0    conda-forge
configparser              3.7.3                    py36_1    conda-forge
cryptography              2.8              py36h72c5cf5_0    conda-forge
cycler                    0.10.0                     py_2    conda-forge
dbus                      1.13.6               he372182_0    conda-forge
decorator                 4.4.1                      py_0    conda-forge
esprima-python            4.0.1                   py_2001    conda-forge
et_xmlfile                1.0.1                   py_1001    conda-forge
expat                     2.2.5             he1b5a44_1004    conda-forge
ffmpeg                    4.1.3                h167e202_0    conda-forge
fontconfig                2.13.1            h86ecdb6_1001    conda-forge
freetype                  2.10.0               he983fc9_1    conda-forge
freetype-py               2.1.0.post1                py_0    conda-forge
fribidi                   1.0.5             h516909a_1002    conda-forge
future                    0.18.2                   py36_0    conda-forge
gdk-pixbuf                2.36.12           haf2c3b9_1004    conda-forge
gettext                   0.19.8.1          hc5be6a0_1002    conda-forge
gevent                    1.4.0            py36h516909a_0    conda-forge
giflib                    5.1.9                h516909a_0    conda-forge
gitdb2                    2.0.6                      py_0    conda-forge
gitpython                 3.0.5                      py_0    conda-forge
glib                      2.58.3          py36h6f030ca_1002    conda-forge
gmp                       6.1.2             hf484d3e_1000    conda-forge
gnutls                    3.6.5             hd3a4fd2_1002    conda-forge
gobject-introspection     1.58.2          py36h5503ade_1002    conda-forge
graphite2                 1.3.13            hf484d3e_1000    conda-forge
greenlet                  0.4.15           py36h516909a_0    conda-forge
gst-plugins-base          1.14.5               h0935bb2_0    conda-forge
gstreamer                 1.14.5               h36ae1b5_0    conda-forge
gtk2                      2.24.32              h586f36d_1    conda-forge
harfbuzz                  2.4.0                h9f30f68_3    conda-forge
hdf5                      1.10.5          nompi_h3c11f04_1104    conda-forge
icu                       64.2                 he1b5a44_1    conda-forge
idna                      2.8                   py36_1000    conda-forge
imageio                   2.6.1                    py36_0    conda-forge
imageio-ffmpeg            0.3.0                      py_0    conda-forge
jasper                    1.900.1           h07fcdf6_1006    conda-forge
jdcal                     1.4.1                      py_0    conda-forge
jpeg                      9c                h14c3975_1001    conda-forge
json_tricks               3.13.5                     py_0    conda-forge
kiwisolver                1.1.0            py36hc9558a2_0    conda-forge
lame                      3.100             h14c3975_1001    conda-forge
libblas                   3.8.0               14_openblas    conda-forge
libcblas                  3.8.0               14_openblas    conda-forge
libclang                  9.0.0           default_hde54327_4    conda-forge
libffi                    3.2.1             he1b5a44_1006    conda-forge
libflac                   1.3.1             hf484d3e_1002    conda-forge
libgcc-ng                 9.2.0                hdf63c60_0    conda-forge
libgfortran-ng            7.3.0                hdf63c60_2    conda-forge
libglu                    9.0.0             hf484d3e_1000    conda-forge
libiconv                  1.15              h516909a_1005    conda-forge
liblapack                 3.8.0               14_openblas    conda-forge
liblapacke                3.8.0               14_openblas    conda-forge
libllvm9                  9.0.0                hc9558a2_3    conda-forge
libogg                    1.3.2             h14c3975_1001    conda-forge
libopenblas               0.3.7                h5ec1e0e_4    conda-forge
libopencv                 4.1.2                    py36_2    conda-forge
libpng                    1.6.37               hed695b0_0    conda-forge
libsndfile                1.0.28            hf484d3e_1000    conda-forge
libsodium                 1.0.17               h516909a_0    conda-forge
libstdcxx-ng              9.2.0                hdf63c60_0    conda-forge
libtiff                   4.1.0                hc3755c2_1    conda-forge
libuuid                   2.32.1            h14c3975_1000    conda-forge
libvorbis                 1.3.5             h14c3975_1001    conda-forge
libwebp                   1.0.2                h576950b_1    conda-forge
libxcb                    1.13              h14c3975_1002    conda-forge
libxkbcommon              0.9.1                hebb1f50_0    conda-forge
libxml2                   2.9.10               hee79883_0    conda-forge
lz4-c                     1.8.3             he1b5a44_1001    conda-forge
lzo                       2.10              h14c3975_1000    conda-forge
matplotlib                3.1.2                    py36_1    conda-forge
matplotlib-base           3.1.2            py36h250f245_1    conda-forge
mock                      3.0.5                    py36_0    conda-forge
moviepy                   0.2.3.5                    py_0    conda-forge
msgpack-numpy             0.4.4.3                    py_0    conda-forge
msgpack-python            0.6.2            py36hc9558a2_0    conda-forge
ncurses                   6.1               hf484d3e_1002    conda-forge
nettle                    3.4.1             h1bed415_1002    conda-forge
nspr                      4.24                 he1b5a44_0    conda-forge
nss                       3.47                 he751ad9_0    conda-forge
numexpr                   2.7.0            py36hb3f55d8_0    conda-forge
numpy                     1.17.3           py36h95a1406_0    conda-forge
olefile                   0.46                       py_0    conda-forge
opencv                    4.1.2                    py36_2    conda-forge
openh264                  1.8.0             hdbcaa40_1000    conda-forge
openpyxl                  3.0.1                      py_0    conda-forge
openssl                   1.1.1d               h516909a_0    conda-forge
pandas                    0.25.3           py36hb3f55d8_0    conda-forge
pango                     1.42.4               ha030887_1    conda-forge
pathlib2                  2.3.5                    py36_0    conda-forge
pcre                      8.43                 he1b5a44_0    conda-forge
pillow                    6.2.1            py36hd70f55b_1    conda-forge
pip                       19.3.1                   py36_0    conda-forge
pixman                    0.38.0            h516909a_1003    conda-forge
portaudio                 19.6.0               hf484d3e_2    conda-forge
psutil                    5.6.7            py36h516909a_0    conda-forge
psychopy                  3.2.4                    py36_1    conda-forge
psychtoolbox              3.0.16                   pypi_0    pypi
pthread-stubs             0.4               h14c3975_1001    conda-forge
py-opencv                 4.1.2            py36h5ca1d4c_2    conda-forge
pycparser                 2.19                     py36_1    conda-forge
pygame                    1.9.6                    pypi_0    pypi
pyglet                    1.4.8                    py36_0    conda-forge
pyopengl                  3.1.3b2                    py_1    conda-forge
pyopenssl                 19.1.0                   py36_0    conda-forge
pyosf                     1.0.5                      py_2    conda-forge
pyparallel                0.2.2                    pypi_0    pypi
pyparsing                 2.4.5                      py_0    conda-forge
pypubsub                  4.0.3                      py_0    conda-forge
pyqt                      5.12.3           py36hcca6a23_1    conda-forge
pyqt5-sip                 4.19.18                  pypi_0    pypi
pyqtwebengine             5.12.1                   pypi_0    pypi
pyserial                  3.4                        py_2    conda-forge
pysocks                   1.7.1                    py36_0    conda-forge
pysoundfile               0.10.2                  py_1001    conda-forge
pytables                  3.6.1            py36h9f153d1_0    conda-forge
python                    3.6.7             h357f687_1006    conda-forge
python-bidi               0.4.2                      py_0    conda-forge
python-dateutil           2.8.1                      py_0    conda-forge
python-gitlab             1.13.0                     py_0    conda-forge
python-sounddevice        0.3.14                     py_0    conda-forge
pytz                      2019.3                     py_0    conda-forge
pyyaml                    5.2              py36h516909a_0    conda-forge
pyzmq                     18.1.1           py36h1768529_0    conda-forge
qt                        5.12.5               hd8c4c69_1    conda-forge
readline                  8.0                  hf8c457e_0    conda-forge
requests                  2.22.0                   py36_1    conda-forge
scipy                     1.3.2            py36h921218d_0    conda-forge
setuptools                42.0.2                   py36_0    conda-forge
six                       1.13.0                   py36_0    conda-forge
smmap2                    2.0.5                      py_0    conda-forge
sqlite                    3.30.1               hcee41ef_0    conda-forge
tk                        8.6.10               hed695b0_0    conda-forge
tornado                   6.0.3            py36h516909a_0    conda-forge
tqdm                      4.40.0                     py_0    conda-forge
urllib3                   1.25.7                   py36_0    conda-forge
wheel                     0.33.6                   py36_0    conda-forge
wxpython                  4.0.6            py36h10a64c0_1    conda-forge
x264                      1!152.20180806       h14c3975_0    conda-forge
xlrd                      1.2.0                      py_0    conda-forge
xorg-kbproto              1.0.7             h14c3975_1002    conda-forge
xorg-libice               1.0.10               h516909a_0    conda-forge
xorg-libsm                1.2.3             h84519dc_1000    conda-forge
xorg-libx11               1.6.9                h516909a_0    conda-forge
xorg-libxau               1.0.9                h14c3975_0    conda-forge
xorg-libxdmcp             1.1.3                h516909a_0    conda-forge
xorg-libxext              1.3.4                h516909a_0    conda-forge
xorg-libxrender           0.9.10            h516909a_1002    conda-forge
xorg-renderproto          0.11.1            h14c3975_1002    conda-forge
xorg-xextproto            7.3.0             h14c3975_1002    conda-forge
xorg-xproto               7.0.31            h14c3975_1007    conda-forge
xz                        5.2.4             h14c3975_1001    conda-forge
yaml                      0.2.2                h516909a_1    conda-forge
zeromq                    4.3.2                he1b5a44_2    conda-forge
zlib                      1.2.11            h516909a_1006    conda-forge
zstd                      1.4.4                h3b9ef0a_1    conda-forge

Hey @psadil,

so I installed a VirtualBox yesterday and played a little with Ubuntu and conda :slight_smile:
If PsychoPy is installed via the provided psychopy-env.yml, libwebkitgtk-1.0 needs to be installed via apt, as it is an external dependency of wxpython that does not yet exist on conda-forge (but wxpython is linked against it). Therefore, the Linux installation instructions should be updated to include this step.

I then ran into a weird issue I couldn’t track down entirely: when running psychopy from the command line, I would always get a segfaul. . I found that the segfault occurs when the app is trying to create the Builder window. However, opening the python REPL and doing from psychopy.app.psychopyApp import start_app; start_app() would launch the GUI just fine! No clue what’s going on there…

1 Like