Experiment unexpectedly ending, no error message

OS: Sonoma 14.5
PsychoPy version: 2024.1.5:
**Standard Standalone?*: yes
What are you trying to achieve?: My experiment ends unexpectedly, with exit code 1 [pid:2186]. There are only warnings and no error messages. I am trying to correct this.

What did you try to make it work?: The experiment has an encoding block, then retrieval, then another encoding block and another retrieval. There is a break between each encoding and retrieval block. After the second break, the experiment ends (whether I end it with a key press or wait for the break to end).

What specifically went wrong when you tried that?: I am attaching a screenshot of the warnings.

Are you using a Mac?

Personally I would recommend 2024.1.4 over 2024.1.5 so it might be worth trying the slightly older version.

I am using a Mac @wakecarter ! I will try the older version and send an update!

I just downloaded 1.4 and I still get the same issue in the same spot, the same warning messages, and no error message! I will try with another computer when I get the chance

Hi @wakecarter thank you so much for your help! We just tried running this on Windows (with the version 1.4) and it seems to end at the same place with the same error and has the same warnings. Do you have other suggestions I could try?

It may be that the error isn’t related to those warnings. Try changing the logging level (in Experiment settings / Data) and also try pasting the full contents of the runner report here.

Also you could go look for the log in last_app_load.log (location somewhere like C:\Users\xxxx\AppData\Roaming\psychopy3)