psychopy.org | Reference | Downloads | Github

Experiment is not working ( Python.ex. has stopped working)

Dear, (Urgent)

My experiments used to work well, But suddenly they stopped working. I installed the latest version of PsychoPy but it shows the same problem. The photos of the dialogue boxes have been attached.

Your help will be very appreciated.


Regards,
Sami

Dear all,

For your information, I am using Windows 7, 64-bit. Also, My experiment includes picture, voice, recording, and text.

The realtek hd audio manager is installed in my PC.

Yor urgent help is very appreciated.

Best regards,
Sami

Hi Sami,

No-one has responded to this message to date as there simply isn’t enough detail to work with meaningfully.

What you need to do is isolate the problem. Make a duplicate testing copy of the experiment and keep removing elements until the experiment runs. Hopefully that will help you narrow down what is causing the problem.

2 Likes

Hi Michael,

Thank you so much for your information.

The problem why the experiment doesn’t run has been solved. My university’s computers are running windows 7 and the version 1.83.4 is the only version which is compatible with my experiment using Windows 7.

However, my experiment requires a participant in each trial ( there are 32 trials) to listen a sentence, select an image, and finally record his voice. The duration for the sound is $sound.getDuration() . The duration for the image is 6 seconds while the recording is 8 seconds. But, the core problem is at some specific trials, some issues appear constantly. In one trial, after the sound finishes, there is a delay that the images don’t appear. This happens to the same trial every time I run the experiment. At other two trials this delay appears but it is very short and the images appear.

I tried to put seconds ( e.x. 5 seconds) for the duration of the sound instead of using $sound.getDuration(), but it shows the same problem.

I run the experiment in my a laptop ( Windows 10) with the latest version of PsychoPy, it is much better, but it is still there is a little delay in the trial in which the images don’t appear completely when version 1.83.4 and windows 7 are used

I hope the description of the problem is clear.

Your help is greatly appreciated.

Regards,
Sami

The latest version of PsychoPy definitely doe run on Win7 (that’s what I use to build/test it).

It might be something about your particular hardware, or your particular experiment, that is the issue but you would need to try and isolate those issues a bit more before we can help you (in the way that Michael suggests above).

Thank you all for your great information.

I did exactly what you asked me to do. I kept removing elements until the experiment run. I found out that the size of some images is too too big which causes a delay. Now the experiment works well provided that it is run on Windows 7 using the version 1.83.4. When the experiment finishes, it shows an error message. I don’t know if that is normal or not. A copy of the message has been attached.

Similarly, I don’t understand why the same experiment doesn’t run using the latest version of PsychoPy with windows 7 although I tried it on my personal labtop and the university’s computer. I kept removing elements until the image component was left alone. When I added any other component ( e.g, text, sound or recording) to the experiment, the experiment didn’t work. This means my experiment only works if leave all components except the image component.I have attached the error message which appears when I press Run.

You suggested the hardware might be the reason. Could you please tell me how I can check if the hardware is the reason? Although I don’t think the hardware is the reason ( I am not an expert) because I tried two different computers.

Note: The experiment is run on Windows 10 if the PsychoPy is the latest version.

Your help is really appreciated.

Many thanks
Sami