Experiment does not run due to Error Messages

I have started programming an Arithmetic Strategy Use task in PsychoPy. The idea is to have a total of 80 arithmetic problems, which would essentially end up being 4 conditions; single addition (20 problems), single subtraction (20 problems), double addition (20 problems), double subtraction (20 problems).

What I have done so far:

  1. I created 4 excel sheets; one per condition with 20 arithmetic problems
  2. I inserted a routine called Trial and inserted 4 loops with Single Subtraction, Single Addition, Double Subtraction and Double addition.
  3. I included a strategy report question after each trial

I tried to run the experiment, however, several error messages keep popping up and I am not sure how to troubleshoot them! Please find the error messages below:

*Traceback (most recent call last): File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/builder/builder.py”, line 1419, in onPavloviaRun File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/builder/builder.py”, line 1413, in onPavloviaSync File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/project.py”, line 844, in syncProject File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/functions.py”, line 148, in showCommitDialog File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 1167, in commit File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/git/cmd.py”, line 542, in File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/git/cmd.py”, line 1005, in _call_process File “/Users/nina/Desktop/PsychoPy.app/Contents/Resources/lib/python3.8/git/cmd.py”, line 822, in execute git.exc.GitCommandError: Cmd(‘/Users/nina/Desktop/PsychoPy.app/Contents/Resources/git-core/git’) failed due to: exit code(128) cmdline: /Users/nina/Desktop/PsychoPy.app/Contents/Resources/git-core/git commit -m _ stderr: ‘fatal: Unable to create ‘/Users/ninajost/Desktop/.git/index.lock’: File exists.

Another git process seems to be running in this repository, e.g. an editor opened by ‘git commit’. Please make sure all processes are terminated then try again. If it still fails, a git process may have crashed in this repository earlier: *

Any tips would be greatly appreciated!

I tried to run the experiment and expected it to run.

Is your experiment saved to your desktop?

Yes the experiment is saved in a folder on my desktop.

Try putting it in a folder in My Documents.

Do you have more than one psyexp file in the same folder?

Hi, I deleted the whole experiment and recreated it. I put everything in one folder and made sure that only one psyexp file is in the folder.

However, I still get the following error messages:

Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/builder/builder.py”, line 1374, in onPavloviaSync
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/project.py”, line 791, in syncProject
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/functions.py”, line 94, in showCommitDialog
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 1102, in getChanges
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/projects/pavlovia.py”, line 946, in repo
AttributeError: The requested local path for project
sits inside another folder, which git will not permit. You might like to set the project local folder to be

Does this help


When you recreate the folder, you could try calling it something slightly different just in case PsychoPy is remembering the old name and location.

When recreating it, make sure you only copy files you’ve created into the new folder, not files (or folders) created by PsychoPy (such as .git)

Nina, you’ve still put that folder on the desktop and on your desktop you have a hidden folder called .git (another git repository). The system we use for synchronisation (git) won’t allow that.

Drag your Strategy folder to somewhere not on the desktop your My Documents or somewhere similar and try again

Hi, thanks very much for your help! I managed to troubleshoot the previous error messages, but when I try to run the experiment, new error messages come up!

6.2248 WARNING Couldn’t measure a consistent frame rate!
Traceback (most recent call last):

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

7.1414 WARNING Couldn’t measure a consistent frame rate!

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

7.2015 WARNING launchHubServer: If using the iohub mouse or eyetracker devices, fullScr should be True.
ioHub Server Process Completed With Code: Negsignal.SIGSEGV
File “/Users/nina/Documents/Strategy/ArithmeticStrategyUse_lastrun.py”, line 92, in
ioServer = io.launchHubServer(window=win, **ioConfig)
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/contrib/lazy_import.py”, line 118, in call
return obj(*args, **kwargs)
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/iohub/client/connect.py”, line 256, in launchHubServer
return ioHubConnection(iohub_config)
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/iohub/client/init.py”, line 296, in init
raise RuntimeError(‘Error starting ioHub server: {}’.format(self.iohub_status))
RuntimeError: Error starting ioHub server: ioHub startup failed.
################ Experiment ended with exit code 1 [pid:90580] #################

Any thoughts on how to troubleshoot them would be greatly appreciated! :slightly_smiling_face:

What (exact) version of PsychoPy are you running? And what version of MacOS? Have you granted PsychoPy access to the Security/Accessibility and Security/InputMonitoring?

Hi Jon, I am using PsychoPy v2022.2.5 and I have a Macbook Air and use version 13.2.1 (22D68) of MacOS. I have also granted PsychoPy access to the Security and Input Monitoring.

same problem, how do you solve it?

Some of my Mac user students had same problem with iohub, switched to psychtoolbox and that worked.