psychopy.org | Reference | Downloads | Github

Experiment built using Builder: Mic does not record the first few trials, then it does record the rest ok

Hello all,

I am a seasoned psychology experimenter, but started using PsychoPy only a month ago.

My message is about microphone. I have noted a number of ‘mic’ issues in the forum, but nothing quite like the one I would like to share here.

Also, I have updated from 3.1.2 to 3.1.5 tody, as the mic seemed to be at stake there.

Thank you all in advance !
Xavier

OS : macOS Mojave 10.14.5
PsychoPy version (e.g. 1.84.x): V.3.1.5
Standard Standalone? (y/n) If not then what?:
What are you trying to achieve?:
I am setting up an experiment in which participants name pictures. The mic is triggered with stimulus appearance and records what participants say for a fixed duration of 2sec.

I have noted that int the first few trials, an empty wave file of the right duration is generated. After a few trials (between 3 and 5 in various tests), the recording starts to work properly midway during the 2 sec window. From there on, all the trials (~15 in the test) are perfectly recorded.

What did you try to make it work?:
I do not seem to get any error message.

I have toggled Hardware/Audio Library between
[‘sounddevice’, ‘pyo’, ‘pygame’, ]
and
[‘pyo’]

I have also tried the demo voiceCapture, adding trials in the loop there.

What specifically went wrong when you tried that?:

Changing the audio library does not change the behavior.

The behavior is replicated with the demo file.

I had overlooked another quite related thread, I am moving this one there:

“stop duration value with mic component causes Psychopy to crash with no error message”

(…apologies…)