psychopy.org | Reference | Downloads | Github

Every psychopy script takes 90 seconds to start

Hi,

i recently upgraded from 1.83 to 1.85 and since then every time i run an experiment I need to wait 90 seconds for the experiment to start. As an example if I try and run the following script:

#########################################
#!/usr/bin/env python2

-- coding: utf-8 --

from psychopy import visual, core

clock = core.Clock()

clock.reset()

print clock.getTime()

win = visual.Window([800, 800], monitor=‘testMonitor’)

print clock.getTime()

win.close()
core.quit()

#########################################

I get the following output:


3.11009353027e-06
90.9487191609
1.9192 ERROR avbin.dll failed to load. Try importing psychopy.visual
as the first library (before anything that uses scipy)
and make sure that avbin is installed.
54.1808 WARNING t of last frame was 4300.09ms (=1/0)
58.4809 WARNING t of last frame was 4300.08ms (=1/0)
62.7809 WARNING t of last frame was 4300.01ms (=1/0)
67.0808 WARNING t of last frame was 4299.87ms (=1/0)
71.3808 WARNING Multiple dropped frames have occurred - I’ll stop bothering you about them!


It seems to get stuck on declaring a window object. Has anyone else encountered this problem, if so if there a work around? Everything was working fine until I upgraded.

BTW I am running windows 10.

Thanks
Martin

In Windows10, there is a good chance that your monitor device has a scaling default that will make a lot of your image presentation a bit wonky. To check, go into your display settings and find your computer resolution, then check to see if that matches the size parameters in your monitor object. If they don’t match, go into your control panel -> display -> and there should be a section called “change size of items” with a link to “set a custom scaling level”, and make sure this is set to 100%.

Restart your computer, then check to make sure that your monitor resolution (in psychopy) matches what you have in your display panel, and try running your code again. Let me know how it goes!

Hi oguayasa,

Thank you for the reply. I tried what you said but it still is the same. Also I tried running the script from the command prompt and I still get the same issue.

Thanks
Martin

For the record I solved this by uninstalling version 1.85, and going back to version 1.83.