Error when switching computer in Builder


I used PsychoPy (I don’t know the version but I downloaded it in june 2019, on Window 10) on my previous computer, but a few days ago I swaped my computer for a new one. It works just fine and my PsychoPy file are correctly processed, except for one thing. Of note, PsychoPy was download on this computer just yesterday, but I did not ‘update’ my files. Each time I open a file, it says ‘From 1.73.04 to 3.2.4: There were many changes in version 1.74.00 that will break compatibility with older versions. Make sure you read the changelog carefully before using this version. Do not upgrade to this version halfway through an experiment.’ Still, I haven’t upgraded anything.

My task requires some routine to appear only if a certain answer has been given right before. More precisely, if the participant answers ‘old’ to an item, a new routine comes up, but if the answer is ‘new’, the loop is directly repeated.

To do that, I added a code in my routine in the ‘Begin routine’ category. The code is the following:

if key_old_new.keys.lower() != ‘s’:
continueRoutine = False

'key_old_new" is the name I gave to the key associated with the routine right before that one, and ‘s’ is the ‘old’ answer.

It used to work perfectly on my previous computer, but here, it does not work properly: the said routine appears whether the answer is ‘old’ or ‘new’.

For now, I haven’t tried anything because there is no error message (as a matter of fact, the task works that way but it’s not what I want). I checked the key name, the allowed answers, but everything is fine.

I don’t know what to do because this code had been done by a colleague because I actually cannot code myself, and before today it worked fine.
I only tried three things:

  • in the code, I changed to ‘key_old_new’ to something that doesn’t exist and it bugs saying that the name does not match a set parameter
  • I changed the ‘.keys’ in the name to something that doesn’t exist and it bugs saying that it does not match a PsychoPy setting
  • I changed the ‘s’ in the code and remplaced it either by the ‘new’ key I set or by a key that is not allowed and nothing changes, the task does not bug but the routine appeared whatever the answer

Thanks already!