Error when finishing experiment on Pavlovia

Hi everyone,

One of the participants trying out my experiment encountered the following error when finishing the experiment (view image):

Can somebody please explain why and tell me what to do to prevent this from happening during my data collection? Thank you.

Do you ever release the reserved credits yourself?

This sounds like the participant tried the experiment twice and a glitch occurred, possibly due to running the experiment just before the fire. Is that possible?

@wakecarter thanks for your reply! The participant tried the experiment today. I have assigned the credits to the experiment, was there another thing I needed to do?

If the participant tried the experiment for the first time today and you haven’t released any reserved credits then I’m afraid that this isn’t something I have any knowledge about.

@thomas_pronk Who would be the best person to look at this?

In case this helps.

I’ll ask around, but first to confirm: @Ivana your Pavlovia username is Domazetoska, and the project name is written-ajt right?

Also tagging @shadinoroozi, since their problem might be related?

Hi everyone,

@thomas_pronk thank you for tagging me.
I have a problem and I would be most grateful if anyone can help me.

The problem is with the error that some of my participants encountered.

This is the error message:

unfortunately, the site keeps the participants’ data on the reserved mode and does not let me see their results. I mean those participants facing this error.

This morning the site released the credit and I lost the data of that participant.
This error has happened before for a couple of my participants but I was able to have their data.

How can this problem be solved?

FYI, I relayed the issue to a colleague.

@thomas_pronk yes, many many thanks!

Hey everyone, just letting you know I had another participant test run the experiment again, it went smoothly this time, so not sure what happened previously. I am still concerned that there’s a risk of that happening again.

Unfortunately, another participant has encountered this error and the data are lost. I really do not know what to do.

Yeah, mine stays on reserved, so weird.

I was just informed that the participant had their browser open for 10+ hours for the experiment. I assume this is the cause for the aborted data, does it make sense?

I never tested a scenario in which I keep a browser window open for 10+ hours, but it does make sense yes; at some point browser sessions start to expire, which means that the server starts to reject communication with the browser. Because PsychoJS tasks only need to talk to the server at the start and at the end, those are the moments it will report an error.

I’ve also got a more general suggestion on how to figure out what is going wrong. If you can reproduce an error or have a participant that you’re in close contact with, then it can be useful to find out what’s reporter in the browser console. See the two tutorials below:

1 Like

Hello @Ivana,

In addition to Thomas suggestion, it is also the case that credits are automatically released after a few hours, to prevent them from being stuck when participants abruptly close their browser mid-experiment. What could have happened, then, is that a credit was reserved when that particular participant started the experiment. The participant then decided to do something else. Several hours later, the credit was automatically released. Later on, the participant returned to the experiment and completed it. When the pavlovia server received the data, it checked the credit and found that it had already been released, and so it complained.
I must say I shall forever be impressed by what participants come up with…