Cannot save results from online experiment (even though I have assigned credits)

URL of experiment:

Description of the problem:
I have been running my experiment on Pavlovia with no problems. I had some subjects who left the experiment before it was over, as such, I released those credits to be able to run them again with new subjects.
However, I noticed that I have not been receiving results from new subjects, while those credits are being consumed and appearing as reserved even though I currently have 7 assigned credits and cannot seem to be getting the results. Meanwhile I have no access to those results as they appear as reserved :confused: Pavlovia is letting me know I have enough credits to run the experiment. I tried to see what was going on by piloting the experiment myself: the experiment works perfectly and once it’s over the following message apears:
Unfortunately, we encountered the following error:

When uploading participant’s results for experiment AgustinSainz/tif
When saving data from a previously opened session on the server
The credit reserved for this session has been released: results cannot be saved

Note: this error appeared to me when I was piloting the experiment again, it works perfectly until the very end
I think the problem has to do with me releasing the credits? Still, I have 7 assigned credits and I do not know what’s going on or how to solve this :frowning:

I have a similar problem. Have you resolved yours? If yes can you share how you solved it?

I wonder if the participant left the experiment running and went back much later. There is a time limit on experiments…though this may be 12 or 24 hours.

I assume you didn’t release reserved credits.

It’s possible that losing Internet access could give this kind of error.

Hi Wakefield,

Yes indeed participant said he left the experiment and came back later. So he must have left it for more than 12 or 24 hours then?

I didn’t release the Pavlovia reserved credits because the option is actually grey out on Pavlovia, I cannot click on it. Is it the case that if I manage to release credit then the data would be saved?

Releasing reserved credits will CAUSE this error, not solve it.

The option may be greyed out if you have no reserved credits or if you have a licence.

Do you think then the data for this participant is lost? I dont have a license but I do have 2 reserved credits (dont know how that happened).

I’ve not yet seen someone recover data after the participant has finished if no files have been saved.