Error when assigning credits - unknown experiment

I get an error when trying to assign credits to a shared experiment (set up by a student) on which I am maintainer - as follows:
Error when assigning credits to an experiment

unknown experiment

If the error persists, contact Pavlovia’s administrator.

Full description:

{
“origin”: “http://pavlovia.org/api/v2/experiments/https://pavlovia.org/hcole/diss_study_task/credits”,
“context”: “when assigning credits to an experiment”,
“pathWithNamespace”: “Pavlovia”,
“deltaAssignedCredits”: 106,
“error”: “unknown experiment”,
“errorCode”: null,
“httpStatusCode”: 404
}
I looked at a previous answer (how-to-assign-credits-to-a-project/9556) but supposedly in principle I can add the credits

That URL doesn’t seem correct. Might this one workout better? Pavlovia

Thanks - but that doesn’t work, gives the same error

Could you make me a maintainer of your gitlab repo so that I can take a peek? My username is tpronk

Done - by the user who is my student - thanks for taking a look!

Thanks! Well, seems I can’t reproduce your steps (I don’t have sufficient rights). I’ll ask someone that does and get back to you

1 Like

Hi - would it be helpful for me to contact someone directly? I am concerned for my students given the delay already with the fire.

Well, to be honest, probably the best way is via me :). The developers that aren’t “client-facing” as it’s called can get a bit flooded by support requests. This means it might take a while before they get to you, but you’re also ensured it won’t fall through the cracks; I’m keeping track.

1 Like

I’m on it, right now. Stay tuned :slight_smile:

1 Like

LOL :slight_smile:

@amorcom Would you share your username and that of the student with me? I understand that one of those is “hcole”

I’m having a similar problem. My username is theoceanistea and my collaborator’s name is amobrien. I’m trying to assign credits to amobrien/swapstudy-final, on which I am a maintainer. I’m getting a “not enough credits available” error, but I have 100 credits available.

yes that’s the one - and mine is amorcom

Hello again,

I believe I have solved the issue, which was caused by a couple of rather tricky little checks, which were still too strict, even after we had relaxed the credit assignment constraints.
As a proof of principle, I have just assigned 10 credits to hcole/diss_study_task from account amorcom, which seems to have worked.
Let me know if you are still experiencing difficulties!
Cheers,

Alain

Thanks Alain - I can see the 10 credits, but I cannot assign any more myself. Would you mind assigning the further 98 which is their max so the students can launch their study? Then I can take them off later if not used (I think!). But there is still some issue and the error message is the same (unless re-login etc needed? I refreshed the page)

The fix worked for me! Thank you!

You would typically need to empty your browser cache first and then reload the page, for the changes to be applied.
But no matter, I am happy to transfer the credits on your behalf. Should all of them go to that one experiment, hcole/diss_study_task?

1 Like

Yes please! Can you transfer 98 of the credits to that experiment? I did clear my cache and re login but the error is still there.

I have just assigned 98 credits to hcole/diss_study_task.
I shall look into the issues you are experiencing independently.
Happy experimenting!

Alain

1 Like