Error running experiment online for the first time

I just finished creating an experiment that runs well on my local device and am trying to create the online version. I received this error message in the console when I tried to pilot the experiment. I am not too sure what these errors are arising from, as the experiment works well on my local device. Thank you!

Link to my github: Sign in · GitLab

Traceback Message Copied Below:

Traceback (most recent call last):
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 1383, in onPavloviaRun
pavlovia_ui.syncProject(parent=self, project=self.project)
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\”, line 741, in syncProject
functions.showCommitDialog(parent, project, initMsg="", infoStream=dlg.status)
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\”, line 94, in showCommitDialog
changeDict, changeList = project.getChanges()
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\projects\”, line 1017, in getChanges
changeDict[‘untracked’] = self.repo.untracked_files
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\projects\”, line 858, in repo
self._repo = self.newRepo()
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\projects\”, line 933, in newRepo
repo = self.cloneRepo(infoStream=infoStream)
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\projects\”, line 973, in cloneRepo
repo = git.Repo.clone_from(
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\git\repo\”, line 1148, in clone_from
return cls._clone(git, url, to_path, GitCmdObjectDB, progress, multi_options, kwargs)
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\git\repo\”, line 1086, in _clone
finalize_process(proc, stderr=stderr)
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\git\”, line 386, in finalize_process
File “C:\Users\emefa\AppData\Local\Programs\PsychoPy\lib\site-packages\git\”, line 501, in wait
raise GitCommandError(remove_password_if_present(self.args), status, errstr)
git.exc.GitCommandError: Cmd(‘C:\Users\emefa\AppData\Local\Programs\PsychoPy\MinGit\cmd\git.exe’) failed due to: exit code(128)
cmdline: C:\Users\emefa\AppData\Local\Programs\PsychoPy\MinGit\cmd\git.exe clone -v https://oauth2:
* C:\Users\emefa
stderr: 'fatal: destination path ‘C:\Users\emefa’ already exists and is not an empty directory.


I’ve realized that when I get rid of the ‘html’ in my experiment URL it removed two errors (Failed to load resources: the server responded with a status of 404 (), however, I am still getting the middle error (/eakwayen/bjt…). Has anyone experienced something similar?

I’m not sure which error you are still having. However, if it’s unknown resources, I’d recommend that you look at these links:


I seem to be having the same issue. I keep getting the 404 error. I’ve looked at the link you provided and have added all my resources to the additional resources tab in the online settings. That did not solve the issue.

I also went through and did the steps you suggested prior. Nothing has worked yet…

I would appreciate any help you could provide.

Has your experiment ever had an html folder?

What is the exact text of your error message?

@wakecarter thank you for this detailed response! I have made all these changes and am about to start from step 7.

Before I do that, I am wondering if I have to change the path that written to find stimuli images in the excel file that is being used for my loop. Currently the path is local to my drive, does this path need to be updated so it can run online? all my stimuli are in a separate ‘resources’ folder. Many thanks!

All resources need to be in the same folder as the experiment or a sub folder. Paths need to be relative so starting with the name of the subfolder.

Getting this traceback error at step 9 (clicking sync with web project). Any ideas on why?

Is this the first sync of a new copy (in which case maybe you need to delete the hidden .git folder first)?

Are you logged in to Pavlovia correctly in Builder?

Yes currently logged in the builder. Where would the hidden git folder possibly be? Currently my online experiment only has my resources folder, data, excel sheets for loop, the actual experiment and its code.

Thank you for the response! It was a 404 error but I was able to export it via HTML and doing that made it work fine.