Cannot upload experiment to Pavlovia: unhandled internal error

Description of the problem:
Hi, I’m trying to upload my experiment to Pavlovia. I am using the Builder and it works just fine offline. When I’m clicking the “Run the study online” key I am receiving this error:

Traceback (most recent call last):
  File "E:\PsychoPy3\lib\site-packages\psychopy\app\builder\", line 1339, in onPavloviaRun
    retVal = pavlovia_ui.syncProject(parent=self, project=self.project,
  File "E:\PsychoPy3\lib\site-packages\psychopy\app\builder\", line 1416, in project
    elif self.filename and pavlovia.getProject(self.filename):
  File "E:\PsychoPy3\lib\site-packages\psychopy\projects\", line 1068, in getProject
    gitRoot = getGitRoot(filename)
  File "E:\PsychoPy3\lib\site-packages\psychopy\projects\", line 1049, in getGitRoot
  File "E:\PsychoPy3\lib\", line 336, in check_output
  File "E:\PsychoPy3\lib\", line 418, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['git', 'branch', '--show-current']' returned non-zero exit status 128.

I am logged in. I tried to upload my real experiment and also a ‘dummy’ experiment with just a trial showing text. Still same error.

Things I have tried so far:

  • Creating a dummy experiment
  • Downgrading the Version from ‘latest’ (v2021.1.0) to 2020.1.3 and 3.0.5

Any help is greatly appreciated!


Hey Julian,

I moved your question to the builder category. Meanwhile, a question/suggestion about your directory structure: often this issue is related with the folder that you’re trying to sync containing orther git repos. Could you try creating a new folder and a new experiment, and sync those?

Best, Thomas

Hey Thomas,

thank you for your response! I fixed the problem in the meantime by just reinstalling PsychoPy.

Best, Julian