psychopy.org | Reference | Downloads | Github

Error message: Unknown resource?

Hi! I’m having a problem with running my experiment on Pavlovia but everything is working fine in builder.

The premise is a reaction time responding to two images presented on screen.The text at the start of the experiment comes up fine but then it gets into the actual experiment. An error message comes up saying that it cannot find the Excel spreadsheet that the loop condition for selecting the stimuli.
I’ve made a few different versions before that have all worked successfully with this excel spreadsheet so I don’t think it’s a problem with the actual document.

It worked when I first checked the piloting but once changed it to running it the error message started coming up and now even if I switch it back to piloting it has the error message.

If anyone has any advice that’d be amazing and I’m more than happy to provide more details if needed

I don’t have a lot of experience but I don’t think you should be using the double dot (. ./) here. This means that you are moving up a folder, to somewhere outside your experiment folder. That may work on your local machine, but Pavlovia doesn’t have access to your entire file system, only whatever is in the project folder.
I suggest you try moving the file ‘DissFinal/FINALImageStimuli.xlsx’ into the resources folder in the html directory. Then, in your experiment, wherever that file is referenced, go change the path so it is referring to the new location, i.e. ./html/resources/DissFinal/FINALImageStimuli.xlsx

Also, you might want to follow this thread: