psychopy.org | Reference | Downloads | Github

Error - Failed to execute send on XMLHttpRequest

URL of experiment: Generation task [PsychoPy]

Description of the problem: This task has been causing a lot of problems to participants, with it sometimes not running, shutting down at points, and now gives the following error attached in the image. Does anyone know what may be causing it? I never experienced problems with this task on my end but it has been a nightmare for participants. Could it be something to do with the browsers? Some mention that switching browsers helps. Not sure how to go about it though and I have lost a lot of data thus far.

@dvbridges
@wakecarter
@jon

I just had a look at your experiment and while sitting on a static instructions screen I was getting a bunch of slow animation warnings in the console.

Do you have any Each Frame code that might be setting text when the text isn’t changing?

I don’t think so, I do not have any Each Frame code as the task consists in having participants guessing the sequence by pressing one of the keys [z, x, n, m] 100 times. After each key is pressed, depending on the key pressed the stimuli will appear in the respective position. As in, if participants press X then the stimuli will appear in the position X which corresponds to centre left.

pressed_key = Guess_inclusion.keys[0]

if pressed_key == ‘z’:
x = -0.650
elif pressed_key == ‘x’:
x = -0.215
elif pressed_key == ‘n’:
x = 0.215
elif pressed_key == ‘m’:
x = 0.650

Smileyface.pos = [x, 0]

Could this be the bit that is causing the problem? It is in the End Routine code and I can always run it smoothly which is very puzzling.

If it helps, I followed the advised provided here: Inverted response time task

What about the first large page of instructions I was looking at? Did it have any code at all, or any components set to Each Frame?

The instructions are very large because they are in two different languages but it is only text and the keyboard to allow them to start whenever they finish reading the instructions.

Dear @jon and @dvbridges

Could you please help me determine why this task is so problematic for participants? It always works well on my end but it causes problems to participants with it often not running adequately and being stuck on initialising. Sometimes changing browsers helps. Could it be something to do with chrome?

Best

@cat500 I have tried to run your task, but I am not sure it is working correctly. I just see 4 blank squares, no images appear. Is the Python version running ok from Builder?

The task is meant to be the opposite of a response time task where participants are expected to guess the sequence of the task that they just done. Thus, they are meant to have the four empty squares and then press the keys “z”, “x”, “n”, “m” in the order they thought the stimuli was appearing. The task is running both on the builder and on pavlovia normally for me but sometimes participants cannot do it, it is not always, some do it with no issues.

@cat500, sorry yes it seems to run ok for me, and I did not receive an error. I do not know why some participants would receive this error, but may be useful to see if there is any error logs stored in the log files of those participants who had the error.

@dvbridges A participant just sent me this, he said it could be related to the display driver but I am not even sure what that means.

Hi, I have the same problem. The error shows up on mine but it works perfectly fine on my own laptop but when i close the experiment it shows on this error. When giving this to participants it sometimes does not start and it seems to freeze the download at the same point (for one participant it’s always 35/62) and sometimes their screen goes black so the experiment crashes. When it does show, my stimuli sometimes plays but it mostly has just the audio. When the experiment crashes it shows the same error message for them but only very briefly. The only advice that I have seen online is to start again which I would rather not do because I have 4 experiments. I am wondering if this is just an issue with pavlovia at the moment because all 4 experiments worked perfectly on my computer yesterday but now all 4 have the same error.

@dvbridges Could there be a problem with the browsers? Some people mention that when they have problems with this particular task, changing browser helps. But I am not gathering data on the browser used, so I wouldn’t be able to determine which one causes problems.