| Reference | Downloads | Github

Error 403 Forbidden nginx when piloting

URL of experiment: Pavlovia

MacOS Mojave, PsychoPy standalone v2020.2.10

Description of the problem: I am trying to run my experiment on Pavlovia. My experiment has uploaded successfully and there is an html folder with and index.html file and two .js files in the experiment folder on my computer. However, I get the error “403 Forbidden nginx” when I try to pilot my press the pilot button.

I have looked at other posts: I have tried to clear my browser cache, remove the html folder and the hidden .git folder and text file. I have tried switching to Inactive and back to piloting again. I have also tried typing “/html/” behind the url in my webbrowser, but this gives the error “No information available for this experiment: it may not exist or you may not have access to it.”

I am not sure why this is happening. This is the first time I am trying to get an experiment running online, so I don’t have much experience and I might be doing something wrong.

Any suggestions are welcome. Thanks in advance!



Could you share the gitlab repo with me so I can take a look? My username is tpronk

Dear Thomas,

Thank you for your swift reply. The link to my repo is:

Let me know if it works.

Kind regards,


I’m afraid you’ll need to add me first (or make your repo public). This page explains how.

Dear Thomas,

Sorry, for this level of dumminess. I don’t really have experience with gitlab. You should have access to my repo now.

Here is the link again:

Thanks in advance.

Kind regards,


No worries :slight_smile:

I think it has to do with the size of your images; they make up 3.7 GB in total, and that’s a bit (well very) hard on our server. Making things worse is that the experiment is exported using an older method that duplicates all images, which is something we improved on in more recent versions.

I recommend to delete the current repo and upload a new one, using the modifications below:

  • Don’t use TIF for images, but JPG or PNG instead (JPG might be best in your case). See this tutorial. NB - that’s a prototype of improved tutorials we’re working on. It will move to one of these days.
  • In online settings, don’t export to an html folder, but leave this empty.
  • Export to the most recent version of psychopy

Best, Thomas

Dear Thomas,

Thank you for your tips. They explain why another experiment (same big set of images, but created in a newer version) did not create a html folder (although it didn’t work either).

I will take a look at the tutorial and reduce the file size.

Kind regards,


1 Like