psychopy.org | Reference | Downloads | Github

Emotiv experiment - propblems in creating file .emotiv_creds

Hello, everyone!
Currently, I am trying to connect Psychopy to EmotivPro to run my experiment in the lab, but I have a problem to create the file “.emotiv_creds” in my home directory. I just used txt file created in my home directory and put there the ID and Password which I got from EMOTIV website (cortex).
Please I hope you can help me as soon as possible:))

1 Like

Hi,

I am having the same problem. Did you find a solution? Thnx.

I have a similiar problem. Once I’ve tested my experiment (with emotiv components in test mode) and worked, I tried to connect psychopy with emotiv. The log info says there is an error, because the .emotiv_creds does not exist.

Could someone post the format or a hint why It does not recognices the file (and thus aborts the experiment)?

Thank you.

Here is the log info

########### Running: C:\Users\ramon\Desktop\prueba emotiv_lastrun.py ###########
2163.7305 EXP Imported Estimulo.xlsx as conditions, 11 conditions, 3 params
2163.7320 INFO Loaded monitor calibration from [‘2021_03_04 22:34’]
2163.7430 EXP Imported Estimulo.xlsx as conditions, 11 conditions, 3 params
pygame 1.9.6
Hello from the pygame community. https://www.pygame.org/contribute.html

0.8363 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’] (in that order).
8.3474 WARNING User requested fullscreen with size [1024 768], but screen is actually [1920, 1080]. Using actual size
Traceback (most recent call last):
File “C:\Users\ramon\Desktop\prueba emotiv_lastrun.py”, line 88, in
cortex_obj = emotiv.Cortex(subject=expInfo[‘participant’])
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\hardware\emotiv.py”, line 71, in init
self.parse_client_id_file(file_path)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\hardware\emotiv.py”, line 256, in parse_client_id_file
raise OSError(error_str.format(client_id_file_path))
OSError: File C:\Users\ramon.emotiv_creds does not exist. Please add Cortex app clientid and secret into ‘.emotiv_creds’ file in home directory

Experiment ended.

There is a missing slash from this error message.

emotiv should be looking for C:\Users\ramon.emotiv_creds (assuming that the file is suppose to start with a dot.

Thank you! The problem was that the emoti_creds had the txt extension. My bad. Now it works perfectly.

Thanks!

Delete the .txt extension in the file. It worked for me