Dialog box: compulsory fields can be skipped by "ok"-click

as I described in an earlier post, I am having some difficulties because of the design change of the dialog box in version 2022.2.4.

Luckily, my resource loading problem now is fixed by using the resource manager. Now, I have a short question concerning the compulsory fields in the dialog box. When clicking on the small “ok” without filling in the compulsory fields, the experiment starts and I can’t assure to get the demographic data I need. What is the best way to deal with this or the easiest alternative? In my case, I don’t intend to use the dialog box data during the experiment, it is just for data collection.

Thank you very much!

Do your have “…” as the default dropdown option?

Try changing it to “” since “…” isn’t blank.

Hi @wakecarter, for your quick reply. I actually had it wrong [‘…’, ‘,…’] but changing it to what is visible in the image didn’t make a difference: you can still skip every question. Though I’m not sure if I understood correctly what you mean with

changing it to “”

, sorry!

I haven’t tested this but please could you try defaults of the form


It might be that the * for compulsory doesn’t work for drop-down menus. Is it working if you leave Alter blank? If not, then it might be an issue with 2022.2.x

I tested what you suggested (see image) and I can still click on the small “ok”-button without choosing any dropdown option and without writing something in the “Alter” field. If I fill every field, the “ok”-button only gets bigger. Might be really an inssue with 2022.2.x because I had exactly the same settings as initially in 2022.1.3 a couple of months ago and it worked perfectly (then existed no small “ok”-button, only “cancel”).

Thank you for looking into this, though :slight_smile:

I don’t know why, but suddenly, the compulsory fields are working again: the “Ok” button is greyed out until every compulsory field is filled :slight_smile: