psychopy.org | Reference | Downloads | Github

Data no longer saving in online experiments

Edit - 2

TL;DR - when piloting my online experiments, when the session finishes or I abort the session the .csv file is downloaded and is as expected. However, it does not appear in the GitLab repo (there is no data folder there at all) and it does not appear when I ask to “download results”. Similarly, there is no saving, as far as I can tell, or the .log files which are essential or of the psydat files.

Edit - 3

I have confirmed that saving works fine in the local psychoPy code, generated from the same psyexp file with no edits, meaning that the issue with saving online is probably not to do with the code (which is consistent with the other observations below) and more to do with the runtime.

The full story

I’ve been setting up my online PsychoJS experiment and frequently testing it whilst it is in pilot phase. All my edits have been done in the builder. Up until yesterday the data saving was behaving as expected…

  • When I ended an experiment prematurely the .csv file would be immediately downloaded, and the the three files (data, log and psydat files) would be present in the .zip file I get when I click “download results”
  • I see an increase in the counter for “aborted” sessions in the piloting tab
  • The data that has been recorded seems complete, containing all the stuff that I would have expected

Now however, something has changed, and I can’t figure out why. Based off the last complete file saves I can tell when the code stopped working, but looking at the commits I have made, I can see absolutely nothing that should change whats been saved or how its being saved. In my last commit I have added some extra stuff to be saved, but by this point the saving was already broken, I just hadn’t noticed yet.

I still see an increase in the count of aborted piloted sessions, but no data files are included in the zip file when I click download results. In addition, no data is being saved in the data directory. I still see a file downloaded when I abort the trial though, but this .csv does not reflect what I have asked the experiment to save.

I figured, given there might be a capacity to the data storage, that I should try deleting all the files in the data directory in the GitLab repo. When I ran my next experiment the file was still downloaded when I aborted the experiment but nothing was saved in the GitLab repo, but the “download results” still returned a zip with the files that I had just deleted! Once I figure out how to make my repo public (I’m not used to gitlab) I will share here, but in the meantime…

Here are my questions -

Any ideas whats going on? Have you seen something like this before?

Is there a storage capacity to the data directory in the GitLab repo?

How much of the data saving is handled by external programs that have a look at the .js code and then decide what to do? The behaviour I’ve observed is simply not explained by the commits and edits I’ve been making which are purely do to with the flow of the program. The commits I have been making have involved moving stuff out of the objects (for example, setting of position on each frame) and into code modules (so that I can set logging to true), so I’m wondering if this has indirectly affected how and where data has been saved? If I compare a functional version of the code (when saving worked) to a current version I can’t see any differences in the set up of the experiment!

Thanks,

Peter

Edit - 1

Both the old working and new not-working versions were running with psychoJS 2021.2.0.

Is it possible that your participants are simply exiting the experiment? How long and/or boring is it? Have you tried turning on “save partial results”?

No, there is no limit to data storage on Pavlovia right now