psychopy.org | Reference | Downloads | Github

Conditions File Extension Not Supported

URL of experiment: Pavlovia
Maddie Quirk / forcedRT to TempHist · GitLab

Description of the problem: I have been stuck on creating this experiment for months now due to Pavlovia errors that pop up randomly and seem to make no sense nor have a clear fix. I have programmed and run this experiment before and this should not be this hard. I have been getting the following “extension not supported” error regarding my entire conditions spreadsheet and haven’t a single clue why. I have made sure there is no extra white space in column headers, I have changed this spreadsheet numerous times, rewritten it, etc.

I had resorted to reverse-designing my experiment via a colleagues of mine that I KNOW runs successfully on Pavlovia and have been syncing to Pavlovia after I make any minor change. I was just finishing up tailoring the practice block to my respective task where it had actually been running just fine until I apparently added an End_Practice text screen following it and then once again received this error when I tried to run it. The last two block loops in the exp I have not touched from the original experiment that I know works online, so I have just been playing with the practice block. This error has still popped up for me too when I create a new psychopy experiment ONLY with the practice block. When I delete any of the components I think may have caused it that I was just changing, the error just continues to persist. It pops up after I press the spacebar to my initial instructions screen.

At this point, it’s been three months of trying to reconcile this same error with minimal help from the forum or documentation and I’m going to have to move to a different program if I cannot fix this soon to collect data for a grant proposal. Apologies for the frustration in this post, but this error now haunts my nightmares and is about to be my grad school villain origin story. Any help would so beyond greatly appreciated. Let me know if I can provide any more information.

I’ve come across this one before. Note that in the error the extension it has a problem with is the file name, not the actual extension.

Please could you show how the file is being selected? I suspect there may be a stray full stop or other punctuation prior to the file name.

Possibly this one

Though it may be related to trying to edit the name of a spreadsheet variable.

I just have it being read in through a trial loop. I’ve changed the name of this spreadsheet at least 10 times to variations without the _ and csv files too across 5 or so different psychopy programs of the same task I’ve tried uploading. The spreadsheet itself was working fine yesterday while I was beginning to build the practice loop and I hadn’t changed anything about it until all of a sudden one sync started reporting this error again.

I have deleted and re-installed psychopy several times thinking it could be something with a backend setting or preference and it appears to not have helped. I’m at a loss and am just really trying to avoid having to learn a new program to code this task.

The task I am building this from that does work in pavlovia uses the same spreadsheets too. This is why I am trying to build my task from this program that I know works, but am somehow still encountering this error. I was thinking it could be something incompatible between my laptop and psychopy/pavlovia, but I’ve never encountered this error before and have run plenty of other versions of this task that worked fine over the last year with the same spreadsheet set up. I’ve updated my laptop to Mac OS Monterey but that didn’t seem to make a difference.

@wakecarter any possible thoughts of other things to try here aside from renaming variable columns, excel files, trying .xlsx vs. .csv, different psychopy programs, etc? I’ve run out of other things to try and am now trying different iterations of devices and just syncing new programs of the same task.

I’d be happy to look into it for you and both fix it for you and work out what the issue was, if you are willing to commission me.

It’s possibly starting to work on a different device, so I’ll investigate that further next week and then will certainly take you up on this if I cannot figure it out!! thank you!

1 Like