psychopy.org | Reference | Downloads | Github

Code name window size on Mac

Hi, I just got started using psychopy on Mac.

Could someone help me how to change the size of the code name window? Somehow it got very large, and I cannot seem to make it smaller.

OS: MacOS 10.12.6
PsychoPy version: 1.85.2
Standard Standalone? (y/n): y

Haha, sorry about that. It was a bug in 1.85.2.
Download the new 1.85.3 and it should be fixed :slight_smile:

jon, thank you very much for your quick reply. But, here is what happened.

  1. I downloaded PsychoPy-1.85.3.zip to update from the psychopy menu.
  2. Update seemed successful (ver. info was updated), but the problem (the name window cannot be resized) still remained.
  3. So, I downloaded StandalonePsychoPy-1.85.3b-OSX_64bit.dmg and replaced new version of PsychoPy2.app with the older version.
  4. Then, when I clicked PsychoPy2.app, the error message showed up (attached), and could not start the app. Restarting OS did not work.
  5. So, I replaced the new version of app with the older version (retrieved from the trash bin), but the same error message showed up.

What did I do wrong? And what can I do? I can live with the not-resizable window for now, but want to start PsychoPy2.app so that I can continue programming.

Thanks.

psychopy error

I used MacOS’s timemachine to go back older version of the PsychoPy app annd updated it using zip file (the step 2 in the previous report). I will stay here for a while.

If it is useful for you to take a look at appData.cfg and userPrefs.cfg when the start-up error occurred, please let me know. I will send it to the mailing list.

Thanks!

I had the same problem, but found using 1.85.3 in Japanese causes this.
Try changing locale setting to another language in 1.85.2 or earlier, then launch the 1.85.3.

1 Like

Ah, yes, it looks like the latest standalone is broken when set to the Japanese locale. If you set your >preferences>app>locale to be English (either en_GB or en_US) then you should be able to load the app and the name box should be correct.

@hsogo12600 Any idea why the 1.85.3 release breaks in Japanese locale? I don’t think I added any new params to _translate(). You can test from the branch r1.85 in the repository.

thanks all

Changing locale to English (US or New Zealand) in my current version (1.85.3) did not make a difference.

And now I think I may have mislead you about this problem. I can resize the code window but not the size of the code-name window independently from the script-window. Perhaps, showing it would be better than writing about it. So I uploaded the screen capture to Youtube.

https://www.youtube.com/edit?o=U&video_id=5ni5NkHRby4

It may come to that I’m just wishing if I could expand the script-window larger size (such as 80% of full screen) so that I can read my long script at once.

Actually I already understood the issue you’re having. I’ve seen it myself before, but I’m not seeing it now, and I’m afraid I don’t know why you are.

jon

Good to know that I did not miscommunicate the issue.

I will install psychopy into other Macs and Windows PCs in September, and report back to you if the same issue is replicated or not.

Appreciate your help!

Sorry for late response.
Today I pulled main branch from upstream and installed it using pip.
Running psychopyApp from Windows cmd.exe to get following error message.
(Win10, WinPython 2.7.10)

C:\Users\Hiroyuki\Dropbox\git-repository\psychopy>python -m psychopy.app.psychopyApp
Traceback (most recent call last):
  File "C:\Users\Hiroyuki\Dropbox\WinPython-PsychoPy\python-2.7.10\lib\runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "C:\Users\Hiroyuki\Dropbox\WinPython-PsychoPy\python-2.7.10\lib\runpy.py", line 72, in _run_code
    exec code in run_globals
  File "C:\Users\Hiroyuki\Dropbox\git-repository\psychopy\psychopy\app\psychopyApp.py", line 62, in <module>
    app = PsychoPyApp(0, showSplash=showSplash)
  File "psychopy\app\_psychopyApp.py", line 138, in __init__
    self.onInit(**kwargs)
  File "psychopy\app\_psychopyApp.py", line 289, in onInit
    self.showBuilder(fileList=exps)
  File "psychopy\app\_psychopyApp.py", line 474, in showBuilder
    self.newBuilderFrame()
  File "psychopy\app\_psychopyApp.py", line 461, in newBuilderFrame
    fileName=fileName, app=self)
  File "psychopy\app\builder\builder.py", line 1035, in __init__
    self.componentButtons = ComponentsPanel(self)
  File "psychopy\app\builder\builder.py", line 696, in __init__
    style=_style, name=categ)
  File "C:\Users\Hiroyuki\Dropbox\WinPython-PsychoPy\python-2.7.10\lib\site-packages\wx-3.0-msw\wx\lib\platebtn.py", line 148, in __init__
    self.SetLabel(label)
  File "C:\Users\Hiroyuki\Dropbox\WinPython-PsychoPy\python-2.7.10\lib\site-packages\wx-3.0-msw\wx\lib\platebtn.py", line 659, in SetLabel
    super(PlateButton, self).SetLabel(label)
  File "C:\Users\Hiroyuki\Dropbox\WinPython-PsychoPy\python-2.7.10\lib\site-packages\wx-3.0-msw\wx\_core.py", line 9207, in SetLabel
    return _core_.Window_SetLabel(*args, **kwargs)
UnicodeDecodeError: 'cp932' codec can't decode byte 0x8a in position 14: incomplete multibyte sequence

I don’t have time to test standalone version right now, but I’ll try it as soon as possible.


Hiroyuki

I’ve tested standalone 1.85.2 and 1.85.3b on my Japanese Windows 7 PC. Both works fine.

Then I run git bisect on my python 2.7 environment on Japanese Windows 10 and found that following commit causes this problem.

https://github.com/psychopy/psychopy/commit/e6a1eddd9e7fd6e663cc35e9be3249cdd993f312

In this commit, “unicode=True” option was removed from trans.install() in psychopy/app/localization/__init__.py. Reverting this line, problem was solved.

-trans.install(unicode=True)
 +trans.install()

I checked psychopy/app/localization/__init__.py of standalone 1.85.3 for Windows and found that “unicode=True” was not removed. This is the reason why standalone 1.85.3 doesn’t show this error, I think.

Guessing from title of this commit, is this modification necessary to support python3?


Hiroyuki

I confirmed that trans.install() is actually gettext.install() and ‘unicode’ option of gettext.install() is removed in Python3. unicode=True is necessary to output translated string in unicode in Python2.
I’ve sent a pull request to fix this problem.


Hiroyuki

Thanks Hiroyuki. I’ve pulled the fix into the repository version. The changes to support Python3 are going to result in a few errors like this I expect. :-/

Just to clarify, does this fix the problem in the original post (with the name box being too big) or just the latter issue you had with the error message?

My commit fixes just the problem 1.85.3 crashes in Japanese environment.
I didn’t experienced the big-name-box issue with 1.85.3.