Changes in the code component of the builder view don't reflect in the file

URL of experiment: Pavlovia

Description of the problem: I have created an experiment in builder view which includes some code components too. I’ve moved it to Pavlovia. I make changes to code components in builder view, click “save”, and then sync it to Pavlovia. When I go to Pavlovia and look at the file, I don’t see the changes I’ve made locally to code component. Why is that? And if my changes don’t reflect in file, it will affect the running of the experiment online. Right?

Have you tried Ctrl-Shift-R (in Chrome) to hard refresh the cache?

Hi @wakecarter, Thank you. By now I opened the Pavlovia on Firefox browser and now I opened it in Chrome but I get this error. While in Firefox I didn’t get this error. I even sync my code again and then tried Ctrl+Shift+R but I still get this error. Is it because of the browser?


Please take a look at my crib sheet for possible causes of the Unspecified JavaScript Error. One common one is a text height of a decimal fraction of a pixel.

Thanks @wakecarter. I looked at the crib sheet but I don’t get it! How can I find it and what does it mean?!

I’m on my phone at the moment

You can search the crib sheet for the “Unspecified”