Can't get past initializing experiment

URL of experiment: Pavlovia
attempt_1 [PsychoPy]
Description of the problem: It works perfectly fine in the builder, but as soon as I upload it to pavlovia it stays stuck in initializing experiment and I can’t move pass that. I have read similar posts indicating that this might have to do with an error in the JS compiling, but I have read and reread my code and I just can’t seem to identify where the bug is :frowning:

Hi, I believe it’s because you haven’t declared your variable image_pool

You could set your code component’s Code Type to Both and within the JS side add

var image_pool;
image_pool = [];

or just add a new code component above the code_image_choosing component with Code Type JS, and add the above 2 lines


Thank you very much for your input.

I tried as you indicated: added a new code component, set it above the code_image_choosing and declared the image_pool variable. However, my experiment is still getting stuck at the initialising experiment… screen :frowning:

Do you have any other hypothesis on what could be happening?

Hey! So I learned how to track errors in the console for Safari and found out that the error you mentioned (lack of declaration of image_pool) was also happening for other two or three variables. I did what you indicated for those variables and now it’s solved! Thank you so much @suelynnmah <3

1 Like