psychopy.org | Reference | Downloads | Github

Builder keeps crashing

If this template helps then use it. If not then just delete and start from scratch.

OS Win10:
PsychoPy version 3.2.3
Standard Standalone? (y/n) If not then what?: No, through pip in a new conda environment
What are you trying to achieve?:
I can import it through Spyder but the app itself won’t load and the experiments won’t run
It just shows a blank screen and crashes (not responding)

What did you try to make it work?: I have deleted the conda environment and tried to avoid pip but the conda - forge didn’t either

What specifically went wrong when you tried that?:
The first clue is that I can’t open the app from the start menu…It shows as if it’s loading and then nothing happens. If I try to run any pre-prepared experiments I get a window popping up but then it crashes saying ‘not responding’…stand alone won’t work either, tried it twice already
I don’t know what I am missing…

It’s up to date btw and all the dependencies are installed in that conda environment

(psypy3_full) C:\Users\ATloo>pip install psychopy --upgrade
Requirement already up-to-date: psychopy in c:\users\atloo\anaconda3\lib\site-packages (3.2.3)
Requirement already satisfied, skipping upgrade: freetype-py in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (2.1.0.post1)
Requirement already satisfied, skipping upgrade: pyosf in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.0.5)
Requirement already satisfied, skipping upgrade: imageio>=2.5; python_version >= “3” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (2.6.0)
Requirement already satisfied, skipping upgrade: python-bidi in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.4.2)
Requirement already satisfied, skipping upgrade: openpyxl in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.0.0)
Requirement already satisfied, skipping upgrade: esprima in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (4.0.1)
Requirement already satisfied, skipping upgrade: scipy in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.3.1)
Requirement already satisfied, skipping upgrade: wxPython!=4.0.2,!=4.0.3; platform_system != “Linux” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (4.0.7.post2)
Requirement already satisfied, skipping upgrade: pypiwin32; platform_system == “Windows” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (223)
Requirement already satisfied, skipping upgrade: gitpython in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.0.5)
Requirement already satisfied, skipping upgrade: python-gitlab in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.13.0)
Requirement already satisfied, skipping upgrade: pyyaml in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (5.1.2)
Requirement already satisfied, skipping upgrade: pyzmq in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (18.1.0)
Requirement already satisfied, skipping upgrade: glfw in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.8.4)
Requirement already satisfied, skipping upgrade: pyWinhook; platform_system == “Windows” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.6.1)
Requirement already satisfied, skipping upgrade: questplus; python_version >= “3.6” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.0.5)
Requirement already satisfied, skipping upgrade: soundfile in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.10.2)
Requirement already satisfied, skipping upgrade: future in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.18.2)
Requirement already satisfied, skipping upgrade: requests[security] in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (2.22.0)
Requirement already satisfied, skipping upgrade: psutil in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (5.6.3)
Requirement already satisfied, skipping upgrade: moviepy in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.0.1)
Requirement already satisfied, skipping upgrade: pandas in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.25.1)
Requirement already satisfied, skipping upgrade: pyqmix>=2018.12.13; platform_system == “Windows” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (2019.1)
Requirement already satisfied, skipping upgrade: sounddevice in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.3.14)
Requirement already satisfied, skipping upgrade: arabic-reshaper in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (2.0.15)
Requirement already satisfied, skipping upgrade: json-tricks in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.13.4)
Requirement already satisfied, skipping upgrade: pyopengl in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.1.0)
Requirement already satisfied, skipping upgrade: gevent in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.4.0)
Requirement already satisfied, skipping upgrade: pyglet in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.4.7)
Requirement already satisfied, skipping upgrade: pillow in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (6.2.0)
Requirement already satisfied, skipping upgrade: msgpack-numpy in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.4.4.3)
Requirement already satisfied, skipping upgrade: astunparse in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.6.2)
Requirement already satisfied, skipping upgrade: matplotlib in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.1.1)
Requirement already satisfied, skipping upgrade: imageio-ffmpeg; python_version >= “3” in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.3.0)
Requirement already satisfied, skipping upgrade: numpy in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.16.5)
Requirement already satisfied, skipping upgrade: tables in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.5.2)
Requirement already satisfied, skipping upgrade: pyserial in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (3.4)
Requirement already satisfied, skipping upgrade: xlrd in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (1.2.0)
Requirement already satisfied, skipping upgrade: msgpack in c:\users\atloo\anaconda3\lib\site-packages (from psychopy) (0.6.1)
Requirement already satisfied, skipping upgrade: six in c:\users\atloo\anaconda3\lib\site-packages (from python-bidi->psychopy) (1.12.0)
Requirement already satisfied, skipping upgrade: et-xmlfile in c:\users\atloo\anaconda3\lib\site-packages (from openpyxl->psychopy) (1.0.1)
Requirement already satisfied, skipping upgrade: jdcal in c:\users\atloo\anaconda3\lib\site-packages (from openpyxl->psychopy) (1.4.1)
Requirement already satisfied, skipping upgrade: pywin32>=223 in c:\users\atloo\anaconda3\lib\site-packages (from pypiwin32; platform_system == “Windows”->psychopy) (223)
Requirement already satisfied, skipping upgrade: gitdb2>=2.0.0 in c:\users\atloo\anaconda3\lib\site-packages (from gitpython->psychopy) (2.0.6)
Requirement already satisfied, skipping upgrade: xarray in c:\users\atloo\anaconda3\lib\site-packages (from questplus; python_version >= “3.6”->psychopy) (0.14.1)
Requirement already satisfied, skipping upgrade: cffi>=1.0 in c:\users\atloo\anaconda3\lib\site-packages (from soundfile->psychopy) (1.12.3)
Requirement already satisfied, skipping upgrade: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in c:\users\atloo\anaconda3\lib\site-packages (from requests[security]->psychopy) (1.24.2)
Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in c:\users\atloo\anaconda3\lib\site-packages (from requests[security]->psychopy) (2019.9.11)
Requirement already satisfied, skipping upgrade: chardet<3.1.0,>=3.0.2 in c:\users\atloo\anaconda3\lib\site-packages (from requests[security]->psychopy) (3.0.4)
Requirement already satisfied, skipping upgrade: idna<2.9,>=2.5 in c:\users\atloo\anaconda3\lib\site-packages (from requests[security]->psychopy) (2.8)
Requirement already satisfied, skipping upgrade: pyOpenSSL>=0.14; extra == “security” in c:\users\atloo\anaconda3\lib\site-packages (from requests[security]->psychopy) (19.0.0)
Requirement already satisfied, skipping upgrade: cryptography>=1.3.4; extra == “security” in c:\users\atloo\anaconda3\lib\site-packages (from requests[security]->psychopy) (2.7)
Requirement already satisfied, skipping upgrade: tqdm<5.0,>=4.11.2 in c:\users\atloo\anaconda3\lib\site-packages (from moviepy->psychopy) (4.36.1)
Requirement already satisfied, skipping upgrade: decorator<5.0,>=4.0.2 in c:\users\atloo\anaconda3\lib\site-packages (from moviepy->psychopy) (4.4.0)
Requirement already satisfied, skipping upgrade: proglog<=1.0.0 in c:\users\atloo\anaconda3\lib\site-packages (from moviepy->psychopy) (0.1.9)
Requirement already satisfied, skipping upgrade: python-dateutil>=2.6.1 in c:\users\atloo\anaconda3\lib\site-packages (from pandas->psychopy) (2.8.0)
Requirement already satisfied, skipping upgrade: pytz>=2017.2 in c:\users\atloo\anaconda3\lib\site-packages (from pandas->psychopy) (2019.3)
Requirement already satisfied, skipping upgrade: appdirs in c:\users\atloo\anaconda3\lib\site-packages (from pyqmix>=2018.12.13; platform_system == “Windows”->psychopy) (1.4.3)
Requirement already satisfied, skipping upgrade: ruamel.yaml in c:\users\atloo\anaconda3\lib\site-packages (from pyqmix>=2018.12.13; platform_system == “Windows”->psychopy) (0.16.5)
Requirement already satisfied, skipping upgrade: setuptools in c:\users\atloo\anaconda3\lib\site-packages (from arabic-reshaper->psychopy) (41.4.0)
Requirement already satisfied, skipping upgrade: greenlet>=0.4.14 in c:\users\atloo\anaconda3\lib\site-packages (from gevent->psychopy) (0.4.15)
Requirement already satisfied, skipping upgrade: wheel<1.0,>=0.23.0 in c:\users\atloo\anaconda3\lib\site-packages (from astunparse->psychopy) (0.33.6)
Requirement already satisfied, skipping upgrade: cycler>=0.10 in c:\users\atloo\anaconda3\lib\site-packages (from matplotlib->psychopy) (0.10.0)
Requirement already satisfied, skipping upgrade: kiwisolver>=1.0.1 in c:\users\atloo\anaconda3\lib\site-packages (from matplotlib->psychopy) (1.1.0)
Requirement already satisfied, skipping upgrade: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in c:\users\atloo\anaconda3\lib\site-packages (from matplotlib->psychopy) (2.4.2)
Requirement already satisfied, skipping upgrade: numexpr>=2.6.2 in c:\users\atloo\anaconda3\lib\site-packages (from tables->psychopy) (2.7.0)
Requirement already satisfied, skipping upgrade: mock>=2.0 in c:\users\atloo\anaconda3\lib\site-packages (from tables->psychopy) (3.0.5)
Requirement already satisfied, skipping upgrade: smmap2>=2.0.0 in c:\users\atloo\anaconda3\lib\site-packages (from gitdb2>=2.0.0->gitpython->psychopy) (2.0.5)
Requirement already satisfied, skipping upgrade: pycparser in c:\users\atloo\anaconda3\lib\site-packages (from cffi>=1.0->soundfile->psychopy) (2.19)
Requirement already satisfied, skipping upgrade: asn1crypto>=0.21.0 in c:\users\atloo\anaconda3\lib\site-packages (from cryptography>=1.3.4; extra == “security”->requests[security]->psychopy) (1.0.1)
Requirement already satisfied, skipping upgrade: ruamel.yaml.clib>=0.1.2; platform_python_implementation == “CPython” and python_version < “3.8” in c:\users\atloo\anaconda3\lib\site-packages (from ruamel.yaml->pyqmix>=2018.12.13; platform_system == “Windows”->psychopy) (0.2.0)

Hi @Anna_Ts, take a look at the trouble shooting guide - https://www.psychopy.org/troubleshooting.html

If you cannot find the solution to your Anaconda installation, you could try installing the standalone distribution of PsychoPy, which is installed with compatible dependencies.