Blank screen when I try to run my experiment on Psychopi

Hi, I’m having issues running a simple lexical decision task on Psychopi. I’m using MacOS version 10.14.6 and the latest version of Psychopi. I have gone through everything step by step but can’t seem to find where I went wrong.
When I click on “run the experiment” I just get a grey blank screen and none of my computer commands seem to be able to make this screen disappear. When I try to close my PsychoPi windows, I get this message:

Traceback (most recent call last):
File “/Applications/”, line 258, in
File “/Applications/”, line 172, in _run
File “/Applications/”, line 102, in
File “/Applications/”, line 98, in main
File “/Applications/”, line 27, in start_app
AttributeError: ‘NoneType’ object has no attribute ‘MainLoop’

I’ve schemed through the forum and upon reading similar stories, I’ve changed the formatting/colour of my instructions/text but nothing seems to work so far. I know nothing about coding so I’m 99% sure there’s something I’m not doing right I just don’t know what it is… I would be so grateful if somebody could help!

Hi @aeyct3,

Are you able to share your .psyexp file here so I can take a look?



Hi Kim thank you so much for offering to have a look at it,

I should have attached the document here but I don’t know if it worked…

Psychopi2.psyexp (12.4 KB)

Let me know either way,
Thanks again!

Hi @aeyct3,

Yes, thanks that worked perfectly.

So I’ve taken a look at your experiment and although I’m not sure that these issues were causing your message I did notice the following:

  1. The size of your text was stopping the experiment running for me. The units you’re using are height units, which means that a unit size of 1 is the height of the screen. As you’d set the text to be 5 for the instructions and 20 for the target word, this was flagging as an error for me. Although not the same one as you were getting. But I’ve changed these now in the file I’ve attached.
  2. You’d set everything else up perfectly, but the variable $word was being used for the target text but not set to every repeat, so that was also stopping the experiment from running. Again that’s fixed in the version here.

Do let me know if this now works for you, they’ve just fixed the problems for me. I’m not sure that these things were causing your error though.

Also, you’ll need to just re-attach your own conditions file as I’ve just quickly created a random one to test this out!
Psychopi2_updated.psyexp (12.3 KB)

Thanks so much,


Hi again Kim,

Thank you so much for your help! I have done everything as instructed. The good news is that though it still wouldn’t work on my laptop, it did work when I tried to run the experiment on somebody else’s laptop. I believe the issue stems from the fact that I am using a MacBook as opposed to Windows?

The bad news is I am now encountering another issue regarding running the experiment online. When I tried to do so, I get a 404 Not Found nginx page. Do you by any chance have any idea why this might be?

No worries if not, you have been so helpful already!
Thanks again,