psychopy.org | Reference | Downloads | Github

Attribute Error: No audio API found. Try installing pyo 0.6.8+, or pygame 1.8+

I am aware that there are other threads on this topic; however, most of them were on Mac. I am currently using Windows 7 and I am almost strictly using builder mode.

The above mentioned error message is displayed whenever I try to run anything on Psychopy. Previously, we were running our lab PCs on XP, and Psychopy never had any issues.

If anyone has any sound suggestions, I’m all ears. Unfortunately, we’re supposed to be running participants this week–so, as you can imagine, this is a time-sensitive issue.

Thanks,

-Drew

Just so we know, what version of psychopy are you running?

Also, does your experiment actually involve playing or recording sound?

Depending on your psychopy version, there is another audio library available, ‘pysoundcard’ . It’s not super well tested, but especially if your experiment doesn’t need audio, put it first in the list in your psychopy settings for audio back end, and I think the error will go away.

The experiment does play sound blasts each time a participant loses a round. Will that make a difference?

Psychopy has the option of three different backends for sound: pyo, pygame, or pysoundcard.

The issue is just that since pysoundcard isn’t super well-tested, it might not work right. If it were me, I would try it. If it doesn’t work, you would just be trading one set of errors for another. But if it works, then great!

The long-term goal is to no longer rely on pyo since it causes a lot of problems, and I’m not sure what their feelings are on pygame.

If pysoundcard doesn’t work, and you wanted to post about the error, we could try to get it working for you (and potentially improve the code for everyone else).

You could also install pygame, I believe there are a number of posts here about installing pygame on Windows (make sure you install it in Psychopy’s interpreter!). But if pysoundcard works out of the box in your case, it will be a much easier solution than installing pygame.

But again, which Psychopy version are you using? I remember at one point there was a mistake and pygame was left out unintentionally.

I’m using 1.84. I’m currently in the process of uninstalling it so I can install 1.82.

And I did try switching to pysoundcard; of course, that only seemed to further equivocate the problem. And I did try installing pygame, but to be honest, I have no idea how it works.