| Reference | Downloads | Github

When running experiment on pavlovia, BFI and Demographics can not be viewed

URL of experiment:

Description of the problem: Hello, I have uploaded my experiment onto pavlovia, however I am having issues. In my experiment I have included the demo for the Big Five inventory as well as the demographics scale. Both of these components run absolutely fine when I run the experiment from the builder, however when my experiment is running on pavlovia both of these components are not visible. I have checked the code and compared it the code for the components in the demo pack and they are they same. Also the questions were created in an excel file, accordingly I made sure that the right file is included. Your help will be much appreciated, thank you in advance.

Best wishes,

If either of those use the “rating scale” component for local experiments, they will not work online: RatingScale in online experiments

As that thread says, you can replace them with “slider” components.

Otherwise, you will need to link to your gitlab repository on pavlovia or give more information about the exact construction of the experiment in the builder.

Thank you for your response, sorry but I wasn’t very clear. What I meant to say is that the demographic form is not visible for participants to note their responses, neither is the BFI form when the study runs on Pavlovia but both of these forms appear and work perfectly fine when I run the experiment from the desktop.

Can you share the psyexp file or the gitlab repository for your experiment? I want to have a look at how those are put together in the first place.

Thank you Yes of course, should I send it via email? or should I share it here (Sorry I am new to the forum).

You can link it here, it’s probably the fastest way. If I can’t help you someone else might be able to.

BigFive, selective attention and varying levels of working memory load.psyexp (130.5 KB)

I have linked my experiment and GitLab repository. Thank you very muchBigFive, selective attention and varying levels of working memory (206.9 KB)

Let’s try this: For each code component, open it and make sure “Code type” is set to “Auto->JS”. Re-select that option if it’s selected to make sure JavaScript code appears in the right half of the code component window. Oh, and make sure you’re on the most recent version of PsychoPy (2020.1.3).

Other than that, I’m not entirely sure what the issue is. The Form component should work in Pavlovia as far as I know.

Thank you, does it matter if I created the experiment on an older version of psychopy but currently running it on the latest version ? If this is an issue how do I update the experiment so that it is compatible with the latest version?

Depending on what version you made it on, the steps I outlined will change what matters. 2020.1.0 added the auto->JS functionality for code components, so if it was made in an earlier version, the code simply wasn’t auto-converted. However, if it was made on a version that could connect to Pavlovia at all, nothing else should need to be changed (in theory).

Since updating the auto->JS functionality for code components and now receiving this error message, also on Pavlovia when I click to pilot I see a forbidden 403 message.

raise ValueError("Found an unexpected change_type '{}' in gitpython Diff".format(this.change_type))

ValueError: Found an unexpected change_type ‘U’ in gitpython Dif

Never seen that one before. @jon?

If you remake the study from scratch in the newest version of PsychoPy (I know, not ideal) it probably won’t have that issue, since it seems to be something about the conversion to javascript being wonky. If you made this in a much older version of PsychoPy initially, that could be it, but I would have expected it to just recompile everything from the builder.

Hello, I tried that and now I am faced with another error. For some reason when I upload the experiment onto Pavlovia I sync the experiment but the platform in which is was created never appears. I a left with a 403 forbidden error message .

That’s very strange. Are you sure that the pavlovia account you have in PsychoPy is the same one you are using to log in to the website, and that you are logged in when you visit the website? This is one where @jon or another website administrator might be needed.

I keep seeing this message when I open the experiment; I wonder if this is causing the issue

Yes I am using the same pavlovia account, thank you for your response

Not sure what’s causing a git difference type of ‘U’. That isn’t in the list of types that gitpython tells us to expect :-/ which are A(dd), M(odify), D(elete), R(ename)

According to the docs of git ‘U’ indicates an “unmerged” file. My guess is that the project has been changed on another computer in a way that has caused a merge conflict (ie the file changed in the same place on multiple computers) and there’s now a merge conflict. We haven’t built in tools to help with sophisticated merge problems like that. I’d suggest you use a more sophisticated tool like GitKraken (free version) to fix the merge conflict. Alternatively you would need to move the files to a new project folder and start again

1 Like