psychopy.org | Reference | Downloads | Github

Using psychopy with a parallel port card


#1

Hi all,

I am wanting to use Psychopy to run an experiment in which it sends a signal to a tms machine. Since new computers don’t have parallel ports, I have attached a parallel port card to the computer and connected the tms machine to this.

However, I am struggling to get the tms machine to fire. Both the demo parallel port code and my code run without error, but the tms machine does not fire.
I was wondering whether anyone has previously used psychopy with a parallel port card? And if so, how did you get it to work?

When I look in device managers at the address of the parallel port it says EFF4-EFF7 and EFF8-EFFF. Therefore would I use 0xEFF4 in my code as the port address?

Any help on this would be greatly appreciated! I’m not sure whether the problem is due to me not having the correct port address, my code to trigger the machine is wrong, or that psychopy isn’t compatible with the parallel port card.

I’ve spent hours looking online but cannot find a suitable answer, and I’m stuck as to where I can get help now.

Thanks,
Emma


#2

There are several posts about it in this website, and most of the time with Windows it has been quickly solved by adding the driver file to the same folder as your script. See my answer here which has a link to an answer on the old psychopy page that has the file I’m talking about (input32.dll).


#3

Hi Daniel,

Thank you very much for your reply. Unfortunately this is not the problem. I have already done this as the script doesn’t run without it. I’ve read all possible posts on here but none of the solutions have seemed to help!

Thanks,
Emma


#4

Hello,

There is also a 64-bit version of the driver. I haven’t used a parallel port in years but I remember having to install inpoutx64.dll to make work.


#5

Thanks everyone for your help. I had just copied the inpout32 files into the folder without installing the driver, which is why it didn’t work!


#6

Glad that the problem is solved. On a more general note, a very helpful tool for troubleshooting of parallel port issues is the LPT Port Test Utility