psychopy.org | Reference | Downloads | Github

Untracked Files Won't Upload Into Pavlovia Repo

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): macOS BigSur
PsychoPy version (e.g. 1.84.x): v2021.2.3
Standard Standalone? (y/n) If not then what?: Y
What are you trying to achieve?:
I’ve been trying to upload an experiment to Pavlovia, but every time I try to push my files into the repo, it says:

“nothing added to commit but untracked files present”

I’ve previously uploaded experiments with no problem, so I’m not sure why this is turning up now.

What did you try to make it work?:

I’ve tried building the experiment again from scratch, and I’ve also deleted the .git and .gitignore files, but neither of them made the problem go away.

What specifically went wrong when you tried that?:
Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/pavlovia_ui/menu.py”, line 110, in onSync
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/pavlovia_ui/project.py”, line 513, in syncProject
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/pavlovia_ui/functions.py”, line 119, in showCommitDialog
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/projects/pavlovia.py”, line 967, in commit
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/git/cmd.py”, line 548, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/git/cmd.py”, line 1014, in _call_process
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/git/cmd.py”, line 825, in execute
git.exc.GitCommandError: Cmd(‘/Applications/PsychoPy.app/Contents/Resources/git-core/git’) failed due to: exit code(1)
cmdline: /Applications/PsychoPy.app/Contents/Resources/git-core/git commit -m dsa
stdout: ‘On branch master
Untracked files:
-3A.png
-3B.png
-3C.png
-3D.png
-3E.png
-3F.png
-3G.png

nothing added to commit but untracked files present’