psychopy.org | Reference | Downloads | Github

Unspecified JS error while piloting

URL of experiment: https://run.pavlovia.org/mieshjelle/test-aida/html/?__pilotToken=c51ce410c124a10e0db5e4b97fc2af39&__oauthToken=54cfe85e439513a6b0d24cb20ad81dd976353d907b37362477b08e1ae98c15ad

(The experiment is in Dutch, I hope that’s not too much of a problem!)

Description of the problem: Everything worked fine when I was in Builder mode, but I knew I could run into some issues when transforming it to online because of JS.

It runs fine through my initial information, and also through the instructions, but then it stops and gives me the Unspecified JavaScript Error pop-up. I have no idea where the error is, or how I’m supposed to find it (if someone could tell me this for future references, that would be very helpful as well!) I am very new to all of this, and not good with JS, so if you could dumb it down as much as possible, that would help a lot! :smile:

Thank you in advance!

Try opening the Web Developer tools in your browser. You may have to look up how to do this online (e.g. for example, in firefox, go to Tools – Web Developer – Web Console or press alt + command + k ). This will give you a traceback of your errors and bring you to the line of code that is causing the problem.

Thank you for the tip, I found how to look at the code! Now it gives me the same error message over and over again, like this:

I read in other queries that they could add Array.prototype.append = .push, but I’m not sure how.

You can click on the underlined text on the right-hand side to see what line of code is causing the hangup (looks like line 1438 in your case). However, if you have custom code elements in Builder, or your original experiment is in Coder, I would recommend that you check out Wakefield’s crib sheet for an overview of best practices.

Thanks again!
i solved it,with help from someone else, apparently I had two variables, one named Number and one named Length, which wasn’t allowed, so I changed those!

1 Like