psychopy.org | Reference | Downloads | Github

Unhandled internal error when opening up a file

hi,
I have encountered an unhandled internal error today, and I wasn’t quite sure if the error is related to a sudden shutdown when running one of my experiment.
I recieve the message whenever i open up one of my experiment:

wx._core.wxAssertionError: C++ assertion “(argtype & (wxFormatStringSpecifier::value)) == argtype” failed at C:\PROJECTS\bb2\dist-win64-py36\build\ext\wxWidgets\include\wx/strvararg.h(449) in wxArgNormalizer::wxArgNormalizer(): format specifier doesn’t match argument type

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “ctypes/callbacks.c", line 234, in ‘calling callback function’
File "D:\Psycopypy\lib\site-packages\pyglet\window\win32_init
.py”, line 635, in f
event_handler = event_handlers.get(msg, None)
SystemError: <built-in method get of dict object at 0x0000013945738870> returned a result with an error set

I was able to run my experiment a few days ago, but it shuts down today at the middle of running through the experiment. I wonder if the problem is related to the message.I tried restarting my computer, but it remains the same.
Thanks a lot.

Did you delete everything from your expInfo dialogue box?

Hi wakecarter, thank you for replying.
I think I didn’t delete anything before the last time turning off the computer, but the computer sort of crashed the last time, Is that something to do with the dialogue box?
By the way, is the expinfo dialogue box a file or a document thing? Does the disappearance mean I have to do it all again:sob:
Thanks again for your help!

The expInfo dialogue box is set under Experiment Settings. It has participant and session as default.

Have you synced to Pavlovia? If so, you could retrieve your experiment from there.

If not then I could probably recreate your experiment file if it isn’t too badly damaged.

Sorry I haven’t synced to Pavlovia.
I appreciate your help very much!! Do I have to give you my psycopy file?

Yes – please send it to me by private message or upload it here

chingtrytry.psyexp (34.9 KB) chingtrytry.py (34.3 KB) chingsheet.xlsx (9.7 KB)
I’m not sure which one you need to recreate the file, so I attached what I have in my computer. I’m still half way through building up the experiment, hope you don’t mind. If you have any suggestions of the file, I will be really happy to hear it. Thanks a lot!

There weren’t any errors when I just opened it.

Does this file open for you?

chingtrytry2.psyexp (34.9 KB)

However, “”.join($keys_resp.keys) in text_feedback shows and error

You could set msg="".join(keys_resp.keys) in Each Frame and then put $msg in the text component.

Thanks @wakecarter I think it was only a computer issue because the error did not come up tonight.
About the “”.join($keys_resp.keys) in text_feedback error I tried using textbox component instead and it worked out pretty well.
However my experiment still encounter a sudden stop after my textbox trial, and I cannot figure out the reason. Can you help me out? Thanks a lot!
chingtrytry0502.psyexp (34.8 KB)

Oh I have solved the problem! Thanks for your help!