Unhandled internal error: unahshable type: 'list'

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): El Capitan 10.11.6
PsychoPy version (e.g. 1.84.x): v2021.1.2
Standard Standalone? (y/n) If not then what?: y
What are you trying to achieve?: Create and run an experiment on Pavlovia

What did you try to make it work?: Synchronise

What specifically went wrong when you tried that?: I got the following message:

Traceback (most recent call last):
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py », line 1320, in onPavloviaSync
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py », line 759, in fileExport
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/scripts/psyexpCompile.py », line 73, in generateScript
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/scripts/psyexpCompile.py », line 242, in compileScript
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/scripts/psyexpCompile.py », line 214, in _makeTarget
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/experiment/_experiment.py », line 242, in writeScript
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/experiment/routine.py », line 140, in writeInitCodeJS
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/experiment/components/slider/init.py », line 256, in writeInitCodeJS
File « /Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/experiment/components/slider/init.py », line 256, in
TypeError: unhashable type: ‘list’

Before the fire, the experiment was operational on Pavlovia, and Psychopy run well on my computer. Now, I can open Psychopy builder, see my experiment, modify it and run it, but I get this error message even without attempting to sychnronise with Pavlovia, and also I cannot synchronise. Please help, I’m running out of time. My student does not have this problem, so I concluded it is not related to the fire.

Thank you,


Try disabling your sliders

Thanks for the suggestion. Still, when i try to synchronize, I get a Gitlab authentification error. It seems that there’s more than one problem.

These are the two last lines:

gitlab.exceptions.GitlabAuthenticationError: 401: 401 Unauthorized

When did you create your Pavlovia account?

It was in january I think. Maybe early february. I can access my account but I can’t snychronize or re-create an experiment.

This may be related to the fact that we’re running on a snapshot from Jan 4th. Hopefuly everything will be sorted early next week.

Actually this was way before. It is an institutional licence. I just started using it in january. Sorry about that. Anyway I’ll just wait monday then, thanks again!

I am having the same problem. Did you solve the problem, if so, could you tell me how?
Thanks in advance.

Are you getting the error message TypeError: unhashable type: ‘list’

I suspect that this is because you are using a variable which PsychoPy sees as a list in context which expects it to be a number or text.

What variables might this be?

Thanks for your very quick response.
I am coppying the error that I am getting. Not exactly the same but mostly. I am very new at this but this error occurred suddenly some time after I was trying to syncronyize the experiment with Pavlovia. But not only this when I just open the Psychopy I am getting an another series of errors. I upgraded Psychopy but nothing changed.

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 1320, in onPavloviaSync
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 759, in fileExport
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 73, in generateScript
compileScript(infile=exp, version=None, outfile=filename)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 242, in compileScript
makeTarget(thisExp, outfile, targetOutput)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 214, in makeTarget
script = thisExp.writeScript(outfile, target=targetOutput, modular=True)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment_experiment.py”, line 242, in writeScript
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\routine.py”, line 140, in writeInitCodeJS
File "C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components\slider_init
.py", line 256, in writeInitCodeJS
stylesListJS = [sliderStyles[this] for this in stylesList]
File "C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components\slider_init
.py", line 256, in
stylesListJS = [sliderStyles[this] for this in stylesList]
TypeError: unhashable type: ‘list’


I’m having the same error message each time I am trying to upload my experiment on Pavlovia. Did someone solve the problem ?

I am using the last version of Psychopy, on Macbook Pro Touch Bar (BigSur) or on Windows 10 and I can’t upload on Pavlovia with both. (I am very new to this)

Thank you