Unhandled internal error- unable to save the experiment (but appears to sync ok from psychopy ok)

It seems I have not been able to save my experiment for the last two hours or so. I am perplexed and don’t want to close the experiment for the fear of losing the new additions. I made the error of updating Psychopy while building a study and started receiving the error described below. I have since been rebuilding the study and it has been saving fine, till now. Any advice/help would be much appreciated, thank you so much. ProxiBots_Japanese.psyexp (43.1 KB)

OS (e.g. Win10): OS 11.2.3
PsychoPy version (e.g. 1.84.x): PsychoPy3 Experiment Builder (v2021.1.2)
Standard Standalone? (y/n) If not then what?: Yes
What are you trying to achieve?: save my experiment

What did you try to make it work?:
Rebuild the study again in a new experiment. Then, it was saving ok till about 2 hours ago. It had happened before, and that time, it seemed to be resolved when I changed slider set up from ['slider] to rating, but perhaps that was just a coincidence. I also tried disabling the slider.
What specifically went wrong when you tried that?:
Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py”, line 686, in fileSave
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/experiment/_experiment.py”, line 331, in saveToXML
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/xml/dom/minidom.py”, line 1968, in parseString
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/xml/dom/expatbuilder.py”, line 925, in parseString
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/xml/dom/expatbuilder.py”, line 223, in parseString
xml.parsers.expat.ExpatError: not well-formed (invalid token): line 1, column 27657

It looks like the error is to do with building the XML output on save… .psyexp files are actually just XML files with a different file extension (so your computer knows to open them in PsychoPy), so I’m guessing there’s something in your experiment that’s been added since the last save which the XML string parser can’t handle. What changes have you made since last successfully saving? In particular, is there any text which you’ve copied & pasted into a component from somewhere else?