psychopy.org | Reference | Downloads | Github

"Unhandled Internal Error" Trying to Launch Experiment Online

URL of experiment: n/a

Description of the problem: When trying to launch a new experiment from builder online for the first time, I get the following error (never had problems previously):

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 1240, in onPavloviaRun
self.fileExport(htmlPath=self._getHtmlPath(self.filename))
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 719, in fileExport
target=“PsychoJS”)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 73, in generateScript
compileScript(infile=exp, version=None, outfile=filename)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 242, in compileScript
_makeTarget(thisExp, outfile, targetOutput)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 214, in _makeTarget
script = thisExp.writeScript(outfile, target=targetOutput, modular=True)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment_experiment.py”, line 252, in writeScript
self_copy._currentRoutine.writeEachFrameCodeJS(script, modular)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\routine.py”, line 329, in writeEachFrameCodeJS
comp.writeFrameCodeJS(buff)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components_base.py”, line 741, in writeFrameCodeJS
self.writeParamUpdatesJS(buff, ‘set every frame’)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components_base.py”, line 405, in writeParamUpdatesJS

File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components_base.py”, line 399, in writeParamUpdates
target=target)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components_base.py”, line 435, in writeParamUpdate
valStr = str(val).strip()
TypeError: str returned non-string (type NoneType)

(Noticed, above was missing last part of error copied here).

Also, the following are things I have tried before posting:
1)rewriting from scratch,
2) moving to c:
3) with any manipulation, I deleted any git/index files that may have been created.
I have also played around with other solutions such as changing the code around. The experiment does work as it should in builder mode.

Did you solve the problem? I get the same message when trying to launch the experiment online.

It worked without a problem when I switched to v2020.1.3 . My experiment was using the code that allows for participant typed input to be collected and visible on the screen. Possibly something with that didn’t work with the newest version, but once I downgraded it worked fined. Note, when going in the backwards direction, I have noticed it is best to redo the experiment again from scratch rather than open something written in the newer with the older version (otherwise there are compatibility issues). Not sure if it that is your issue, but might be worth a try.