psychopy.org | Reference | Downloads | Github

Unhandled internal error- please help?

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): win 10
PsychoPy version (e.g. 1.84.x): 3
Standard Standalone? (y/n) If not then what?: standard standalone- y

What are you trying to achieve?: Trying to use the app. My app was working last night but now when I try to use it with any of my saved experiments I run into an “unhandled internal error” Here is what the window gives me. Can someone help?

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app_psychopyApp.py”, line 888, in onIdle
idle.doIdleTasks(app=self)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\idle.py”, line 105, in doIdleTasks
_doTask(taskName, app)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\idle.py”, line 142, in doTask
currentTask’func’
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\pavlovia_ui\menu.py”, line 97, in setUser
pavlovia.getCurrentSession().setToken(token)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 412, in setToken
self.startSession(token)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 437, in startSession
self.gitlab.auth()
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 196, in auth
self.token_auth()
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 209, in token_auth
self.user = self.objects.CurrentUserManager(self).get()
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\exceptions.py”, line 242, in wrapped_f
return f(*args, **kwargs)
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\mixins.py”, line 68, in get
server_data = self.gitlab.http_get(self.path, **kwargs)
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 517, in http_get
streamed=streamed, **kwargs)
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 491, in http_request
response_body=result.content)
gitlab.exceptions.GitlabAuthenticationError: 401: 401 Unauthorized

What did you try to make it work?:
I tried opening the program using different experiments, I tried restarting the program, restarting my laptop, & uninstalling and reinstalling python. I get the same result.

What specifically went wrong when you tried that?:
See error message above

Hi There,

Are you still encountering this error? it looks as though you might be trying to sync to an account that you are not logged into on your local psychopy? please can you try selecting the second globe from the right to check?

Thanks,
Becca

Hi! It looks like it had logged me out of my git lab, once i logged back in and added an SSH key things seem to be working alright now!
The problem I’m running into now is when I switch from inactive to pilot and the page never finishes loading on pavlovia…