psychopy.org | Reference | Downloads | Github

Unexpected keyword argument ‘languageStyle’

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): Mac 10.13.6
PsychoPy version (e.g. 1.84.x): v3.0.0b10
Standard Standalone? (y/n) If not then what?: y
What are you trying to achieve?: I’m getting an error about LanguageStyle for TextStims when running a builder experiment. The error is:

Exception ignored in: <bound method TextStim.del of <psychopy.visual.text.TextStim object at 0x127fcbfd0>>
Traceback (most recent call last):
File “/Users/orruser/.psychopy3/versions/psychopy/visual/text.py”, line 177, in del
GL.glDeleteLists(self._listID, 1)
AttributeError: ‘TextStim’ object has no attribute ‘_listID’
Traceback (most recent call last):
File “/Users/orruser/Desktop/vts_reward_draft.py”, line 134, in
depth=0.0);
TypeError: init() got an unexpected keyword argument ‘languageStyle’

What did you try to make it work?:
Removing languageStyle='LTR' from each TextStim in coder after compiling the builder script and running from coder worked. I’m suspecting this is a bug. I’ve uploaded my builder file.vts_reward_draft.psyexp (38.9 KB)

Check your “Experiment Settings” dialog box. Is it possible that you have selected an option under “Use PsychoPy version” that is earlier than when the new language style attribute was added?

Thanks

Its set to latest. When I initially made the file 3.0.0b10 was an option (like the below screen shot from my laptop), but there is now just a blank where that option used to be on the lab computer. I won’t be running it on the computer I was testing earlier, so I’ll check the testing computers to see if 3.0.0b10 is available there, or try with ‘latest’.

That maybe indicates that the lab computer is running an earlier version. The languageStyle setting is a relatively recent addition.

Thanks I’ll look into that.