psychopy.org | Reference | Downloads | Github

Undefined Error When Piloting on Pavlovia

URL of task code: https://gitlab.pavlovia.org/djangraw/ratemovietask

Description of problem: When I go to my Pavlovia dashboard, click the task, and click “Pilot”, I am sent to https://pavlovia.org/undefined , a page that says:

We could not find a record for experiment designer: undefined

Please check the name and try again. If the error persists, contact Pavlovia's administrator.

Does anyone know why this might be happening or how I can fix the issue?

Update: I deleted the git repo both locally and remotely and reinitialized it. When I went on the Pavlovia dashboard and tried to set its status to “Piloting”, I got the following error:

Error when fetching information about the experiment: djangraw/ratemovietask
>>> undefined

If the error persists, contact Pavlovia's administrator.

Full description:

"<html>\r\n<head><title>502 Bad Gateway</title></head>\r\n<body bgcolor=\"white\">\r\n<center><h1>502 Bad Gateway</h1></center>\r\n<hr><center>nginx</center>\r\n</body>\r\n</html>\r\n<!-- a padding to disable MSIE and Chrome friendly error page -->\r\n<!-- a padding to disable MSIE and Chrome friendly error page -->\r\n<!-- a padding to disable MSIE and Chrome friendly error page -->\r\n<!-- a padding to disable MSIE and Chrome friendly error page -->\r\n<!-- a padding to disable MSIE and Chrome friendly error page -->\r\n<!-- a padding to disable MSIE and Chrome friendly error page -->\r\n"

After a refresh, the repo seemed to be in the pilot state. But when I click “pilot”, I get the same “undefined” error as before.

@apitiot, this may be a question for you: do you know how I can get my Pavlovia experiment back to a state where I can pilot it?

Did you ever find a solution to this? I’m having the same issue.

I never did get the original version working, but I did find a workaround: I forked the repo into a group namespace. That forked version has been running fine. The original, however, still gets an error message, which is now: “403 Forbidden; nginx”.

Unfortunately this didn’t work for me but thanks for the suggestion