Uncaught ReferenceError: log4javascript is not defined

Description of the problem: Hi everyone,
The experiment worked fine when I used PsychoPy builder on my computer. However, when I put it online, it was stuck on “initialing the experiment” in the pilot mode. I checked the “Developer Tools - Console” and found

“Uncaught ReferenceError: log4javascript is not defined
at new PsychoJS (/Danielle829/si_exp/lib/core-2021.1.2.js:1603:45)
at /Danielle829/si_exp/Experiment.js:17:18”
as shown below:

When I clicked the link, line 1603 from core-2021.1.2.js showed:

and line 17 from Experiment.js showed:
“const psychoJS = new PsychoJS({”

I’m new to Python, JS, and PsychoPy and I’m confused about what I can do for debugging. It seems to me that this error occurs earlier than loading the first code block. Any ideas on how to fix this error? Thank you!






(Hi, Wen! This picture shows all the documents that I have uploaded online. )

Dear @Danielle,

I have just had a look and it appears that you have updated your experiment, which is now running without issue, as far as I can tell. I believe that all is well, then?

Incidentally, it would be best if you could keep public conversations to English. That makes it possible for everyone to read your messages, potentially help you, and potentially benefit from the help that you got.
Thank you very much!


Dear @apitiot,

Thanks for your message! I’ve updated my Psychopy version from 1.2 to 2.3, and the same error didn’t occur again. Maybe updating to the latest version can be helpful.

Later, I also encountered several issues such as “.download Resources() is not a function” and “unknown resource”. Then I added my files into “Edit experiment settings” - “online” - “additional resources”, and these issues were solved. Now my experiment is running and I finally got time to update this post. Apologies for my late reply.

Best wishes,

That is no problem at all. I am very glad that all was well in the end.
Best wishes,