Uncaught (in promise) TypeError: when running a survey post Jan update

Hi folks,

Got a strange error when trying to run a survey after the latest upgrade to surveys. The survey worked before the upgrade in january. I wonder if there is a problem parsing the JSON? I have attached it to this email for someone to take a look. For example, is there some syntax that might be messing this up? It doesn’t seem to throw any syntax errors.

ProblemSurvey.json (27.9 KB)

Any help appreciated.



I get the same error when I import your JSON. The length in question refers to surveyData.surveys[surveyIdx].pages[i].elements.length

The issue is caused by your Thank You page which has a description but no questions (elements).

Personally I discourage such pages because participants may think they have already finished and close the browser tab without submitting (less likely with Pavlovia Surveys than Qualtrics because of the “Changes that you made may not be saved.” warning). However, to fix your issue change that thank you message to an HTML question so the page has an element.

Thanks Wake! I’ll keep that one in my back pocket, as its bound to come up again!