psychopy.org | Reference | Downloads | Github

Unable to run PsychoPy2 version 3.0.6 on Kubuntu 18.04 LTS after installation

If this template helps then use it. If not then just delete and start from scratch.

Kubuntu 18.04 LTS :
PsychoPy2 version 3.0.6:
Standard Standalone? y :
I want to install and run PsychoPy2 version 3.0.6 on Kubuntu 18.04 LTS:

** I did the following:

wget -O- http://neuro.debian.net/lists/bionic.de-m.full | sudo tee /etc/apt/sources.list.d/neurodebian.sources.list

sudo apt-key adv --recv-keys --keyserver hkp://pool.sks-keyservers.net:80 0xA5D32F012649A5A9

sudo apt-get update

sudo apt-get install psychopy
**:

**After installing it I tried to start psychopy from the console (using the start menu did not work). This is the output message I got:

File “/usr/bin/psychopy”, line 62, in
app = PsychoPyApp(0, showSplash=showSplash)
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/_psychopyApp.py”, line 180, in init
self.onInit(testMode=testMode, **kwargs)
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/_psychopyApp.py”, line 219, in onInit
from psychopy.app import coder, builder, dialogs
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/coder/init.py”, line 9, in
from .coder import * # pylint: disable=W0401
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/coder/coder.py”, line 22, in
import psychopy.app.pavlovia_ui.menu
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/pavlovia_ui/init.py”, line 19, in
from .functions import *
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/pavlovia_ui/functions.py”, line 13, in
from ._base import PavloviaMiniBrowser, PavloviaCommitDialog
File “/home/NAME/.local/lib/python2.7/site-packages/psychopy/app/pavlovia_ui/_base.py”, line 9, in
import wx.html2
ImportError: No module named html2

I checked the version (psychopy --version). This was the output:

PsychoPy2, version 3.0.6 ©Jonathan Peirce 2015, GNU GPL license

Did anyone have the same problem and knows how to solve it?

Thanks in advance for the help.
**

@dls, can you please tell me what version of wxPython is packaged with your version? I believe this error occurs because html2 was introducted in wx versions > 2.9, so you will need at least wxpython version 2.9 to run PsychoPy 3.0.6

@dvbridges, thank you for the reply. I ran the following command:
python -c “import wx;print wx.version
The output was: 3.0.2.0

Is this the information you needed? Or do I have to run another command to find out which version of wxpython was packaged with psychopy? In that case please tell me how to retrieve the required information.

Does anyone have the same problem?

Does anyone know how to deal with this problem?

Nobody?

Hi @dls, Jon recently updated the Linux installation method on the website. Have you tried this method?

Hi @dvbridges. Thank you very much. After reading the new Linux installation method that you suggested I ran the following command:

python3 -m pip install psychopy

This installed Psychopy v3.1.0. And it seems to work perfectly. Thanks again.

I still don’t know which version of wxPython is running with Psychopy. Maybe someone on this board has an idea how to retrieve the required information?

1 Like

To see the version of wx that PsychoPy is using, go to Coder view in PsychoPy. In the Shell tab, import wx and check the version using wx.__version__ or wx.version().

@dvbridges Thank you for your reply. I followed your instructions. The version of wx on my system is ‘4.0.1 gtk3 (phoenix)’.

Great, are you still having the original problem with PsychoPy3 running on Python 3?

@dvbridges No. It seems to run smoothly now.