psychopy.org | Reference | Downloads | Github

TypeError cannot read property "getExtension" of undefined

URL of experiment: https://pavlovia.org/bobbyTUCI/sandwichtrial

Description of the problem:
I made a basic experiment that I will need to add more features to later, but for now I am just piloting it to ensure the basic idea works.
When piloting the study everything works fine except that once I get to the very end of the experiment (i.e. hit the space key on the very last routine) I get the following error message:

I havent been able to find anything else in the forums about this specific error, so I am unsure what might be causing this. I had custom code components in the experiment before just to modify text positioning on each trial, but deleted that and just manually adjusted the text components positions, but that didn’t seem to fix anything
I appreciate any help.
-Bobby

Hi @Bobby_Thomas, I have not been able to replicate the error with the current version of your task. Try refreshing your browser cache and running the experiment again. If the error happens again, please press F12 and copy the error in the console tab, and paste it here.

I refreshed my cache but am still getting the error. The errors in the console tab are pasted below:
core-3.2.js:1052 TypeError: Cannot read property ‘getExtension’ of undefined
at Window.close (core-3.2.js:343)
at Scheduler.quitPsychoJS [as _currentTask] (PavlovTrial.js:895)
at Scheduler._runNextTasks (util-3.2.js:1079)
at Scheduler._runNextTasks (util-3.2.js:1082)
at update (util-3.2.js:1046)
log4javascript.min.js:1 FATAL unknown | {}
BrowserConsoleAppender.append @ log4javascript.min.js:1

When I expand on the error I get:
VM509 core-3.2.js:1052 TypeError: Cannot read property ‘getExtension’ of undefined at Window.close (VM509 core-3.2.js:343) at Scheduler.quitPsychoJS [as _currentTask] (PavlovTrial.js:895) at Scheduler._runNextTasks (VM511 util-3.2.js:1079) at Scheduler._runNextTasks (VM511 util-3.2.js:1082) at update (VM511 util-3.2.js:1046)

window.onerror @ VM509 core-3.2.js:1052
error (async)
_captureErrors @ VM509 core-3.2.js:1051
PsychoJS @ VM509 core-3.2.js:837
(anonymous) @ PavlovTrial.js:14

Interesting. I just reset my entire PC and now it works just fine. I’ll mark the topic as solved and will reply again if the issue raises its head again. Any idea why resetting the PC would have fixed this?

A participant has just sent me a print-screen of the exact same error. The error appeared right at the end of the experiment (similar to Bobby_Thomas’s issue).
Crucially, the data for this participant was not saved (which means I do not have her results but obviously have to pay her for her time…).

I understand that for Bobby_Thomas the problem was resolved by restarting the PC, but this should still be an open issue since restarting the PC is only effective if you are piloting - not if you distribute the experiment to participants…

I’ve had the same error reported today.

Noted, just removed the solution tag and hopefully someone will be able to help address this

Good afternoon,

I believe the issue has to do with those occasions when an experiment is running on a browser not compatible with WebGL.
I have just fixed the problem. All should be well, now.
Best wishes,

Alain