psychopy.org | Reference | Downloads | Github

Two subsequent routines with sound not possible

Hello,
below is core problem with an intended sound experiment.
Thank you very much for any help!
Best, M.

OS (e.g. Win7):
PsychoPy version (e.g. 1.90.3):
**Standard Standalone? (y)
What are you trying to achieve?:
Two routines with sound: Routine 1 (sound with tone A for 1 sec), Routine 2 (.wav file, 5 min)

What specifically went wrong when you tried that?:
Tone A is played but then PsychoPy “breaks down”

Include pasted full error message if possible. “That didn’t work” is not enough information.

From cffi callback <function_StreamBase.ini..callback_ptr at 0x0FEF02B8>:
Traceback (most recent call last):
File “C:\Program Files (x86)\PsychoPy2_PY3\lib\site-packages\sounddevice.py”, line 733, in callback_ptr
return_wrap_callback(callback, data, frames, time, status)
File “C:\Program Files (x86)\PsychoPy2_PY3\lib\site-packages\sounddevice.py”, line 2508, in _wrap_callback
callback(*args)
C:\Program Files (x86)\PsychoPy2_PY3\lib\site-packages\psychopy\sound\backend_sounddevice.py", line 194 in callback
toSpK[:len(dat), :] += dat # add to out stream
ValueError: non-broadcastable output operand with shape (128,1) doesn’t match the broadcast shape (128,2)

This looks like a stereo sound issue, with suggested fix here: Error message and sound

I looked for the “Force stereo” box in the Experiment Setting but there is no
such box.
My Experiment Setting menu consists of:
Basic: Experiment name … Use PsychoPy version
Data: Data filename … Logging level
Online: Output path … OSF Project ID
Screen: Monitor … Blend mode

I don’t know whether it is the best solution but my experiment works now.
In the Preferences Settings under ‘audio library’ I had 3 audio libraries:
‘sounddevice’, ‘pyo’ and ‘pygame’.
I just deleted the ‘sounddevice’ library and now my experiment works fine : )